TechSpot

cd autorun

By suszannah
Sep 4, 2007
  1. Hi there, hoping someone can give me some new ideas on this (easy please) my autorun on cd drive seemed to vanish a while back, I have checked the registry settings 91/145 (with a little help)....

    I have also checked everything in properties (E drive) and they all seem fine....

    I have run Microsofts autofix and that showed up nothing, really stuck now, no idea what else to try.......

    I was advised to run Combofix a few weeks ago and it quarantined 'autorun.inf.vir' from my D drive (recovery drive) although avast and superantispy say it is clean, problems did start before this file was moved....

    Hp Pavillion a708.uk
    xp Home
    SP2 all patches in place

    any help appreciated
     
  2. Rik

    Rik Banned Posts: 3,814

    Try uninstalling your drive in device manager then rebooting your pc, it may help.
     
  3. suszannah

    suszannah TS Rookie Topic Starter Posts: 32

    Thank you for that, but unsure how to do it, as I don't have any disks, all preinstalled by HP I just have a recovery drive....... :(
     
  4. Rik

    Rik Banned Posts: 3,814

    The lack of a windows disk wont be a problem.

    Click start, control panel, switch to classic view if its not already on it. Click on system then hardware then device manager. Open cd/dvd rom drives, locate your drive and right click and select uninstall.

    When you reboot your pc it will automatically pick up the drive and install it.

    It may or may not cure your problem, let me know how you get on.
     
  5. suszannah

    suszannah TS Rookie Topic Starter Posts: 32

    Well have tried Rik's solution, found new hardware on reboot.........nope no autorun, it is more annoying than anything else I want to know where it went and why lol

    Really nervous of the registry, not that confident on it......is there an easier way?
     
  6. Rik

    Rik Banned Posts: 3,814

    It could quite easily be caused by malware. If you want to have your system checked out then go to the Security and the Web forum, read all the sticky threads, then make a post there.
     
  7. suszannah

    suszannah TS Rookie Topic Starter Posts: 32

    hi Rik, i am a a member of the avast forum, had a serious infection of 'vundo' a few months ago....(that was a bad one)..... :(

    Used superantispy, spyware terminator, Avg....eventually cleared it (6 pages on avast forum lol)
    Think that thread will go down in history!!!!

    so everything is scanned, scanned and rescanned, if anything gets in here, it deserves a medal lol
     
  8. suszannah

    suszannah TS Rookie Topic Starter Posts: 32

    yes James there is, 0x (lots of 0's) then 01 (1)...i havn't messed with anything, honest........:)
     
  9. suszannah

    suszannah TS Rookie Topic Starter Posts: 32

    Yes that was already selected..........sorry for being a pain :(
     
  10. suszannah

    suszannah TS Rookie Topic Starter Posts: 32

    Hey neighbour....... Beddau near pontypridd


    Think I better get the guy out to see to it, have an extended warranty so if I need a new drive it will be FREE lol
     
  11. suszannah

    suszannah TS Rookie Topic Starter Posts: 32

    Got the addy down, sure i will need more help soon lol
    Thank you for all your help......

    will be a regular here from now on ......... :)
     
  12. suszannah

    suszannah TS Rookie Topic Starter Posts: 32

    Well just a little update..... called the warranty people they are going to put a new cd/dvd drive in for me on monday.......watch this space :)
     
  13. suszannah

    suszannah TS Rookie Topic Starter Posts: 32

    Hi again, Tech guy came out, installed new cd/dvd writer.....and guess what.... 'No Autorun' he says its a software problems somewhere.....
    which is a great help to me :)

    Guess I will just have to learn to live with it :)
     
  14. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    You should have a file autorun.inf on your system somewhere and the path command should be pointing at the host directory, size about 29k. Have a search and see if it is there - perhaps renamed to autorun.old?
     
  15. suszannah

    suszannah TS Rookie Topic Starter Posts: 32

    Thanks Codex, it's not a major disaster, but thank you anyway :)

    Hi Albert, There was such a file in my D drive (recovery) 'autorun.inf.vir' Combofix quarantined it and as I was told it was safe to delete it, so I did ..........
     
  16. suszannah

    suszannah TS Rookie Topic Starter Posts: 32

    thanks james... a query mine was set last week to 91/145 what does this setting mean?

    lol I bet you wished you hadn't met me ;)
     
  17. suszannah

    suszannah TS Rookie Topic Starter Posts: 32

    ok thanks will do tomorrow when brain is half awake :)
     
  18. suszannah

    suszannah TS Rookie Topic Starter Posts: 32

    James...... you will not believe this (dancing here) lol


    as a last resort I use microsoft autofix...(for the third time) and it worked

    maybe the combination of a new drive...... and uninstall of Spyware Terminator

    so nice to have it back...... :) :)
     
  19. suszannah

    suszannah TS Rookie Topic Starter Posts: 32

    Well now what can i worry about????

    mmmmm need help with Nero.....new thread on the way :)
     
  20. matav

    matav TS Enthusiast Posts: 144

    install the Windows XP Powertool "TweakUI" and search for autorun, then enable/disable autorun feature on any drive you want.
    in your case, enable it on your Disc Drive.
     
  21. suszannah

    suszannah TS Rookie Topic Starter Posts: 32

    Well I have just installed Nero Essentials and it's huge I only want smartstart and nero vision, can I just have those instead of half a gig of things I will never use?

    Has enough manuals to fill a library... lol no idea where to start :)
     
  22. matav

    matav TS Enthusiast Posts: 144

    yeah... you should choose custom setup to install only the feature that you want.
    or go to add/remove programs from control and select NERO and click on "Change"
     
  23. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Give this Microsoft Autoplay Repair Wizard a try.

    It often works, where all else fails. I`ve used it to good effect myself on quite a few occasions.

    Regards Howard :)
     
  24. suszannah

    suszannah TS Rookie Topic Starter Posts: 32

    Thank you all for your help and advice......seems to be going a lot better and used the custom install on Nero.......so can give you all some peace for a little while...... ;)
     
  25. Jase123

    Jase123 Banned Posts: 1,012

    Not all CDs will start automatically when inserted. They must contain a file called AUTORUN.INF. If the CD has autorun.inf and does not automatically run, perform the following steps to ensure the CD-ROM drive setting Auto Insert Notification is checked.


    Click the Start button, point to Settings, and then click Control Panel.
    The Control Panel window appears.
    Double-click the System icon.
    Click the Device Manager tab.
    Click the plus (+) sign next to CDROM.
    Double-click the CD-ROM drive model.
    Click the Settings tab.
    If the Auto Insert Notification checkbox is unchecked, click to check it.

    Regards Jase
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...