CD ROM drive not working

By Sosa11
May 21, 2007
  1. Hello!

    On my other PC I was messing about with the boot sequence in the BIOS setup (so the CD drive preceeded the hard disk) and since I moved the boot sequence back to the default settings the CD drive's not been working.

    It says the drivers are either missing or corrupt; and uninstalling/reinstalling the drive has no effect, and a driver update search just says the ones already installed are up-to-date.

    Could it be because the CD drive isn't high enough in the boot sequence? I can't remember exactly what the default sequence was but I've just checked it on this fully functional machine and the CD drive is first in the sequence with the hard disk second.

    Annoyingly the PC is at another house which I won't be at until Thursday and there's no net access there.

  2. Mugsy

    Mugsy TS Guru Posts: 361   +9

    This may sound like a dumb question, but I've got to ask:

    Did you move the jumpers to change between Master or Slave?

    You didn't say. You may simply have forgot to change the drive status when you moved it back.
  3. Sosa11

    Sosa11 TS Rookie Topic Starter

    Sorry, you'll have to bear with me I'm afraid, what are the jumpers? I only changed the boot sequence and nothing else, could they have changed automatically and so need changing back?
  4. mailpup

    mailpup TS Special Forces Posts: 6,964   +355

    Jumpers are on the back end of optical drives and have to be physically moved to change the settings. If the drives were working before and you didn't move the drives, IDE cable or the jumpers, then they should be okay.

    Try uninstalling the IDE controller instead of the optical drives. Go to the Device Manager and find the IDE ATA/ATAPI controllers and uninstall the controller that the optical drive is connected to. Reboot and let Windows reinstall install. See if that helps.
  5. Mugsy

    Mugsy TS Guru Posts: 361   +9

    If he doesn't know what "jumpers" are, he probably shouldn't be fooling around in the Device Manager. :)

    On the back of most all IDE devices, there is a tiny box-like "cap" (for lack of a better word) that fits over just two pins (usually you'll see two rows of four pins with a "jumper" connecting two pins (one above the other). You can have up to four IDE devices in your computer: Master-0/Slave-0 and Master-1/Slave-1 You can have a Master device without a slave, but not vice-versa. If you have two devices on the same IDE cable, one must be set (using the jumpers) to "Master" and the other "Slave" (it usually says on the drive which pair of pins you must jump to set it). The first pair is typically "Master", the second "Slave", the third is "Cable Select"... which only works if your motherboard supports it, and it typically flaky, so don't use it... and a null "test" pair.

    There should be an IDE-0 and an IDE-1 on your MoBo (REALLY new boards only have one, preferring to use SATA instead.) If you have two drives on the same cable, one must be set to "Master" and the other "Slave" or else the PC will try and access both at the same time (causing neither to work).

    Hope this helps.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...