computer asking me which OS to boot?

By k1n9k00p4
Feb 11, 2006
Topic Status:
Not open for further replies.
  1. I bought a new 160gig harddrive today and it needed formatting for it to work so i used the windows XP setup CD to format.

    NOTE* I installed the new harddrive as slave because i allready had 1 harddrive with winXP on.

    SO i though id format the newhardrive with the windows xp cd, install xp then boot to my first harddrive and then i right clicked on the new drive icon and selected "format".

    But when i start my computer now it askes me which windows XP installation i want to boot to and they both are exactley the same. If i choose the newhard drive installation it says files missing. It boots ok on to my master hardrive.

    Is there a way i can stop it asking me which OS to boot and make it just boot to the master harddrive all the time?

    Cheers.
  2. Vigilante

    Vigilante TechSpot Paladin Posts: 2,120

    I'm not 100% sure what you're trying to do. Did you WANT to load XP on the 160gig new drive? Or just have it blank to use as a 2nd drive? If you just want a blank drive, then format it from your existing Windows. Which it sounds like this is what you did eventually. Correct me if I'm wrong.

    Otherwise, the boot menu is handled in the boot.ini file on your primary drive root folder. Usually C:\boot.ini.
    To edit the values:
    Right-click My Computer - Properties. Go to Advanced tab and click Settings under the 'Startup and Recovery' section. At the top there is a button called "edit". Click that and it will open your boot.ini file, ready to edit.

    In order to have just one OS, there should be ONE entry under [operating systems]. Mine looks like this:
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect


    Whichever one you don't want, remove it.
    The entry in the [boot loader] section is the "default" entry which it will boot to when the time is reached. Here is my whole file:

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect


    Notice the default entry is the same as the entry below. This is a standard, single OS. It won't pop up the menu even though the timeout is 30 seconds because there is only one OS listed.

    Anyway, it isn't as complex as it may sound here. If you don't know which entry is a good one or bad one, then just change the text from "Microsoft Windows XP Professional" like mine says, and change it to like "Test OS 1" and "Test OS 2". Then when you figure out which one is the right one, delete the other one and rename the good one.

    That should be enough info to get you going. Good luck!
  3. mailpup

    mailpup TS Special Forces Posts: 8,382   +205

    I think the mistake you made was to install XP on the new hard drive while it is already on the old drive. To format the new, second hard drive, you don't need to insert the cd. You should have gone to Control Panel > Administrative Tools > Computer Management > System Tools. Select the new drive and partition/format it.
  4. k1n9k00p4

    k1n9k00p4 Newcomer, in training Topic Starter Posts: 110

    yes, i just wanted the new harddrive blank to store data on. When i first connected the harddrive it did not appear in my computer. But it did appear when i boot to the winxp cd.
  5. Vigilante

    Vigilante TechSpot Paladin Posts: 2,120

    It wasn't there because it was not partitioned yet.

    Most hard drives don't come partitioned out of the box, or formatted for that matter. And Explorer won't show a drive unless it is formatted and given a drive letter.

    You have to use Disk Manager to partition and format a new drive. The quick way to get there is to right-click My Computer and choose Manage. Disk Manager is in there.

    Have you fixed your problem yet with boot.ini?
  6. wlknaack

    wlknaack Newcomer, in training Posts: 149

    If I understand what you have written, you formatted and installed WinXP on the new drive, booted to your system drive, and reformatted the new drive again, wiping out the WinXP installation. If this is correct, and you do not want a WinXP installation on your new drive, you can solve the erroneous dual boot situation as follows:

    Start/Run/typed "msconfig" in the dialog box (without the quotations)/OK

    Select the Boot.INI tab and click on the "Check All Boot Paths" button, and when the invalid boot path is presented to you, select the delete option, click OK, close the Configuration Utility, reboot, and the dual boot option screen will no longer appear.
  7. k1n9k00p4

    k1n9k00p4 Newcomer, in training Topic Starter Posts: 110

    Ok it sorted, I just format the first harddrive, and it seems to be working fine now ^_^.

    thanks for the advice guys.


    Yeah i edited the boot.ini file but instead of 2 "Windows XP Proffesional" coming up, there was one "windows XP" professional" and on "Windows DEFAULT".

    But its sorted now.

    Thanks again guys.
  8. wlknaack

    wlknaack Newcomer, in training Posts: 149

    Take a look at your boot.ini file again: I think you will find the "Default Windows" under "boot Loader," and the "Windows XP Professional" under "Operating Systems." This is normal.

    What I think you had before was two (2) "Windows XP Professional" listed under "Operating Systems," one of which was invalid because you reformatted the slave drive after installing XP, thereby eliminating the XP installation. However, the boot loader information is contained in the boot sector of your system drive, so although you erased XP on the slave, the system drive continues to give you the OS choice screen. By editing the Boot.ini as I suggested, you removed the invalid (i.e. in your case non-existent) boot path.

    I do not think your formatting of the slave drive again did anything to fix the problem.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.