Computer Fried?

By ruck101
Aug 24, 2005
  1. The other day I was playing World of Warcraft on my computer and all of the sudden it shuts off. I go to turn it back on but nothing happens. I noticed a smell coming from the power supply and figured it had fried. So I bought a new one (520w) and threw it in. The computer will now power on but I get ''No Signal'' coming from the monitor when I connect it to the video card. I reattatched all the cables inside but it does not help. Could the power supply have caused my video card to fry as well, or even the entire motherboard? The AMD chip seems to be working at the very beginning but the whole thing seems to stop responding after a few seconds. Here are my specs:

    AMD 64 2800 (Brand New)
    Gigabyte GA-K8NS Motherboard
    1 gig of PC2700 Ram
    Soundblaster Live Value

    Any tips and advice would be appreciated. Thanks!
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Please would you take a few moments to read this post. A message for all newcomers. Thanks.

    I would be inclined to agree with your assesment that, it`s either a bad videocard, or the mobo.

    Try changing the videocard. If that doesn`t work then I`m afraid it looks like your mobo has fried.

    Regards and good luck Howard :wave: :wave:
  3. ruck101

    ruck101 TS Rookie Topic Starter


    Thanks for the help howard. I'll search ebay for a video card replacement. Let's hope its just that...
  4. ruck101

    ruck101 TS Rookie Topic Starter

    Tried Videocard

    Ok, seems the videocard isn't the problem. I put it in another computer and the monitor is fine. *sigh*....does this mean its the mobo and processor for sure? Or is there any other possibility? Thanks
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...