Computer keeps waking from sleep

By bz0190
Feb 8, 2016
Post New Reply
  1. I purchased a Dell XPS 13 about 2 months ago and it keeps waking up from sleep. This problem first manifested itself a few weeks ago and I turned off wake timers etc and it was fine for a few weeks but now the problem has resurfaced.

    Today, I ran ''powercfg -waketimer'' command on CMD and there are no active wake timers on my PC. I also ran the ''powercfg -devicequery wake_armed'' command and there are no devices that can wake my PC. Finally, a couple of days ago I also completely disabled ''allow wake timers'' in advanced power settings but today I checked and this was enabled for some reason so I disabled it again (maybe this was the cause)? Is there anything else I can do to fix this recurring issue?

    It's getting really annoying as my laptop decides to randomly wake whilst it's in my laptop sleeve in my bag and it gets really hot and runs down my laptop's battery meaning I can't use my laptop when I need it when out and about.
  2. sol1109

    sol1109 TS Member Posts: 43

    Do you have an Asus router? I have the same problem with multiple devices and it is the Asus router firmware keeping track of what is on the network for its network map utility. It started about six months ago with one of the router updates, is a known issue, but has no resolution yet.
  3. jobeard

    jobeard TS Ambassador Posts: 9,156   +598

    Inspect the NIC and the WiFi drivers for the Wake-on-Lan setting being active.
  4. bz0190

    bz0190 TS Rookie Topic Starter

    Doesn't the fact that the ''powercfg -devicequery wake_armed'' command show no results indicate that there are no devices that can wake my PC? Either way, I went to Device Manager and under Network Adapters there was only one device. In properties for that device, the box that says ''allow this device to wake up the computer'', wasn't ticked so that device can't be the issue.

    This issue persists at both my home and my parents' and we both have the ISP issued routers..
  5. bazz2004

    bazz2004 TS Evangelist Posts: 1,214   +200

    Hopefully this question won't annoy you but what is wrong with shutting the laptop down when transporting it? Maybe I'm missing something here.
  6. jobeard

    jobeard TS Ambassador Posts: 9,156   +598

    Good, that's the right device and choice to which I was referring to. It is MASSIVELY different than the pc powercfg.
    Consider a server in a light's out room (eg no one on site). The manager can send a WAKEONLAN packet to the NIC and cause the system to come out of sleep or even hibernation.
  7. Technician

    Technician TS Addict Posts: 677   +113
    Is Wake On Lan enabled? Here's a walkthrough that describes all the ways to enable it in Windows 10.
    How to Change Automatic Maintenance Settings in Windows 10
    An unsupported usb driver, when the device was plugged in can keep the screens from sleeping or caused intermittent sleeping.
    or try this:
    Win10 was waking up every 15 or so minutes for me. Using Event Viewer, I found that the Windows Time service was waking up the PC to notify me that the time had been changed. I went to Control Panel -> Date and Time and unchecked "Notify me when the clock changes", but why was it doing that so often? While still in the Date and Time Control Panel, I clicked the Internet Time tab, clicked Change Settings and switched to, then pressed "Update now". When I went back to the Internet Time tab, it now says "Next synchronization:" one week from now. The problem seems to be solved now.
    Cobalt006 likes this.
  8. jobeard

    jobeard TS Ambassador Posts: 9,156   +598

    BRAVO - - good use of the Event Viewer!!
  9. bz0190

    bz0190 TS Rookie Topic Starter

    Event viewer says:

    Change Reason: System time synchronized with the hardware clock.

    Basically the above is waking up my PC at random times in the morning. I have followed the steps suggested by Technician but my time was already set to synchronise with And the box with ''notify me when the clock changes'' was already unticked. Really annoying how this problem keeps persisting. Any other clues?

  10. bazz2004

    bazz2004 TS Evangelist Posts: 1,214   +200

    Shut the thing down when it's being transported. If it was mine I'd always have a worry that it would switch on in the bag and overheat.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...