TechSpot

Computer not booting

By Hodsocks
Jun 25, 2013
Post New Reply
  1. Hi guys, can you help me out? I have a PC that would not boot up, all it would do was fire up for a couple of seconds and then turn off again, nothing on the screen at all, tried a new PSU but no change. Thinking it was the mobo I changed it for a new one (Asrock), my choice of mobo is restricted as its a socket 775.
    The new mobo only supports DDR3 memory so I dropped in 2 sticks of crucial memory, the old one was DDR2. The processor is a core2 duo.
    I turned on the PC and the fans and lights come on but that's all, no beeps or anything on the screen. They do now stay on so I guess I have made some progress. :)
    I reseated everything, tried only one stick of memory, tried another PSU, reseated the CPU but still won't boot up, I reset the CMOS with a jumper but whatever I try gets me no closer to a resolution.
    Have you guys any suggestions?
     
  2. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 8,560   +2,901

    Are you connecting the 4pin/8pin ATX12V power from the PSU on the motherboard?

    [​IMG]
     
  3. Hodsocks

    Hodsocks TS Guru Topic Starter Posts: 372

    Of course and re seated it several times.
     
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Any beeps from the motherboard with no memory installed?
     
  5. Hodsocks

    Hodsocks TS Guru Topic Starter Posts: 372

    Not a squeak.
     
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    The motherboard is bad...
     
  7. Hodsocks

    Hodsocks TS Guru Topic Starter Posts: 372

    I was beginning to wonder that too, looks as though I will need to rma it.
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...