TechSpot

Computer not recognizing any USB ports...

By jezebelstorm
Nov 29, 2007
  1. Everything was working fine until I tried to print something. I got a message that the device (printer) was not recognized and to click on the balloon. The I got the message that none of my USB ports were recognized. How can this just all-of-a-sudden happen? I tried uninstalling and reinstalling my printer but the problem seems to be with the USB ports themselves. When I check in Device Manager I am told that all the ports are working properly. However, none of the ports are recognized and just a couple of days ago, everything worked fine. I have no idea of what to do and any help will be greatly appreciated!
     
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,915   +167

    This could be a power supply problem
     
  3. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,623   +320

    Check your device manager for any unrecognised hardware.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.