TechSpot

Computer turns on but no screen

By Scout Trelan
Apr 24, 2009
  1. MOTHERBOARD: M3N-HD HDMI
    CPU: AMD 6400 duo core
    RAM: 4gigs
    Video: Geforce 8900

    I was playing a game when the system just turned off. Prevously, I had a few times it reboot. The system will turn on ( fans and leds' ) and HD loads and CD loads but I get no video on monitor nor do I hear any system beeps or seems like it is getting past the BIOS load. I took the machine to a shop and they said my PSU was bad... So I purchased a new one online since nobody locally carries anything above a 450w same one as I had before 700W. I installed new PSU but I get the same simptoms.

    I took out the motherboard out of the case and put only 1 stick of ram in it reseated the cpu with heatsink and fan with new heat paste. Plugged in the VGA adaptor for onboard video. Plugged power into the motherboard at the main adaptor and the cPU 12v. I short the power swt to turn it on and I get the same thing. Fans turn on LED on. No beeps or video. I tried a 2nd speaker and tried again no change. Any suggestions?
     
  2. davisjaron

    davisjaron TS Member Posts: 82

    It's possible you let your computer get too hot and it burnt up the motherboard... that or possibly the graphics card... if it's getting power but not posting, then it's not your power supply, although it may have been bad too. It's either going to be your motherboard, graphics card, or processor... a failure in either three could cause it to not show up... You saying it doesn't have any bios beeps leads me to believe it's either the motherboard or the processor, not just the graphics card.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...