Computer won't boot

By spicyhamster
Sep 11, 2006
  1. Yesterday I was surfing the net and was about to shut it down when pop! blue screen of death. I rebooted, and when it powered up, long beeps (like 5 secs each) came from the mobo spkr and nothing came up on the sceen but the beeps kept coming. I dont know what to do! lately I had been having some problems with artifacting and cooling and such. do you think this has anything to do with that?

    My Specs are:
    Pentium D 3.0 GHz dual core
    512 RAM
    250GB Hard drive
    ECS C19-A SLi mobo
    XFX GeForce 7600 GS

    Any help at all would be much appreciated, because at this point, I can't use my own computer at all. Thanks in advance.
  2. Lekki_Sheep

    Lekki_Sheep TS Rookie Posts: 135

    Please go to this URL and check the codes against your beeps:

    If you've had problems with cooling I'd guess it's probably related, but unless you can get it going after you've left it for a good amout of time to cool I'd say that the problem is that something has popped and is now dead. You didn't mention hearing a bang, so fingers-crossed it's probably just a ramstick (ram doesn't have any capasitors on it and they're the things that go bang).
    Beep code for repeating is memory error, so it's probably the RAM.

    Hope it helps.
  3. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...