TechSpot

Computer Won't Start

By SexyLexie729
Jun 8, 2005
  1. Hi,
    I don't know much about computers so here goes. I had a computer built for me 8 months ago. One day I tried to start my computer and it wouldn't start. The fans don't turn on, absolutely nothing happends...not even the LED lights in the front turn on. I checked all the outlets and that doesn't seem to help. I was wondering if this was a problem with my power supply. Any insight would be fantastic. Thanks!!!
     
  2. mailpup

    mailpup TS Special Forces Posts: 6,980   +362

    Check the back of the power supply and see if the on/off switch is on.
     
  3. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    It does sound like a psu problem.

    The fact that your system is only 8 months old means it will still be under warranty.

    Take it back to who ever built it for you, and have them look at it.

    Regards Howard :wave: :wave:
     
  4. SexyLexie729

    SexyLexie729 TS Rookie Topic Starter

    I don't have an on/off switch on the back of it.
     
  5. SexyLexie729

    SexyLexie729 TS Rookie Topic Starter

    Unfortunetly, a friend of a friend of a friend built it for me and I have no idea how to get ahold of him.
     
  6. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Oh dear.

    In that case may I suggest that you take it to your local pc repair shop.

    Regards Howard :cool:
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...