TechSpot

connected to internet but browser doesnt work

By 20legend
Oct 22, 2007
  1. My laptop is connected to the internet and programs like AIM work, but neither Mozilla or IE will pull up a webpage. I have Symantec Anti-virus because my school requires it. But my desktop works fine at school, its just my laptop.
     
  2. Daveskater

    Daveskater Banned Posts: 2,031

    Hello, 20legend, and welcome to Techspot :wave:

    Please take a look at the following threads to make your experience here as enjoyable as possible :)

    Message for all newcomers

    SNGX1275's Guide to making a good post/thread

    The Techspot FAQ

    If you could take a minute to fill in some of your profile information that would be helpful to all members of the forum :)
    Knowing someone's location in the world can be extremely helpful, even if you just put a country.

    Also remember to post any problems or questions that you have in the appropriate forums

    With regards to your problem, if you're having this problem at home, try restarting your router by unplugging it form the mains, waiting about 10 seconds then plugging it in again. Make sure the settings are saved first though ;)
     
  3. Cinders

    Cinders TechSpot Chancellor Posts: 1,313   +12

    Do you have a proxy server at school? If you do you may need to tell your browsers where it is. Or you may need to give those programs permission to access the net through your firewall.
     
  4. 20legend

    20legend TS Rookie Topic Starter

    I checked the Windows firewall and its allowing Mozilla and IE. It was working for the first month of school, then it just quit working one day.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.