TechSpot

connecting 2 laptops with crossover cable

By Raist
Oct 1, 2005
  1. Hi all!
    I'm a complete ***** in this sort of thing so please bear with me. I have 2 laptops. my old one is a toshiba satelite with winxp pro sp1. using avast antivirus and zone alarm firewall. I have been using this laptop to connect to adsl so i think i have the ethernet connection (i think). my new laptop is a dell xps2 with winxp home sp2. I'm also using zone alarm and avast antivirus here. Can anyone guide me step by step to connect these 2 laptops? I got to the point where i created new connectoin but from here onward i really have no idea what to do. I read this link: http://www.razertech.com/edge/hardware/crossover/crossover.htm like someone suggested but I really don't know how to do it.
    What i want to do is for the 2 laptops to share file. So for example I can burn DVDs with my new laptop from my old one.
    can anyone please help a newbie???
    Please?
    Thank you!
     
  2. rear_engine

    rear_engine TS Rookie

    Computer 1: 192.168.1.100
    Computer 2: 192.198.1.101
    The subnet mask entry must also be identical on both machines.
    Example: 255.255.255.0
    I believe from the above you will find he is using a router to put both machines on a home network and the internet by the 192.168.1.100 and etc. as these are router addresses. I assume you do not have a serial port on one or both laptops. But you have USB and printer ports you can use. You will need a software piece for this if not loaded. Router $35 is the route I would go. My suggestion is to go to windows help or website and search. I once had a printer cable I fixed to do this and used Norton Commander, But have not done this in ages. Look for how to do it with a usb cable or get a router. With the router you set the computer that you want to get info from to share files. But caution if network (router) is connected to internet because anyone can get inside while set this way. But all you have to do is unplug internet from router and you have your own network (connected or not). I use a Linksys BEFSR41 & would not have a wireless as my Toshiba laptop connects with someones every time I turn it on unless disabled.
     
  3. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Nothing to do with a router at all!
    Both PCs/laptops need to have a networking port (RJ45).
    Just go buy the crossover networking cable. To verify: hold both ends together with the push-lever away from you. If the colour sequence of the 8 wires from left to right is identical, you have a straight cable, otherwise it's a crossover cable.
    Setup PCA with IP=192.168.0.1, SNmask=255.255.255.0, default-gateway=192.168.0.2
    Setup PCB with IP=192.168.0.2, SNmask=255.255.255.0, default-gateway=192.168.0.1
    You can leave the DNS-servers blank.
    Both PCs must be in the same WORKGROUP and in the network settings, File and Printer sharing should be enabled.
    On each PC, in Windows Explorer, rightclick the whole drive, directory, subdirectory or only file(s) that you want to share, select Sharing and Security... and set to your liking.
    That's all.
     
  4. Raist

    Raist TS Rookie Topic Starter

    Hi! thanks for all your replies!
    Sorry I'm not so clear about the setting up connection still. OK, I do own a crossover cable. I connected each end to the laptops. Afterwards I clicked on " create new connection", "set up an advance connection, connect to other comp using serial, pararel, or infrared port", "accept incoming connections", and then I have to choose the connection device. Is this the way to go? After I have this connection installed I could not find the SNmask and the default-gateway option. The only option I had was when I click on TCO/IP proprties, I get to choose to specify the to and from TCP/IP addresses. If you could give me a hint or an instruction to reach the point on where you advise me I would really appreciate it.
    Thanks!!
     
  5. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    You need to set up a home or small office network. Then manipulate the network settings as described.
     
  6. Raist

    Raist TS Rookie Topic Starter

    hi!
    thanks for replying realblackstuff! sorry haven't been able to reply for ages. I tried what you told me to do. My old laptop used to be connected to a network in my uni, so i do have some share folders there. ok, I did what you told me to do, I connected both laptops with the cross over cable. I could see my uni shared folders from my old laptop in my networks places in my new laptops, so it should be connected, right?? but when I clicked on the folders it says that I may not have permission to access the folder. So I tried to make new shared folders in my old laptop ( I right clicked the folders and clicked share) but I can't see this folders in my new laptop. Does anyone know why? Now when I got to my network places without even being connected I still could see my uni shared folder in my new laptop, how come?? please help!
    Thanks!
    Raist
     
  7. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,714   +397

    For simplicity's sake set them on the same WORKGROUP, you can do that by right clicking on My Computer and going to one of those tabs, I'm not on my PC right now so I dont' remember which one it is. But set up both comps on the sameone, then if you still have problems accessing. Run the network setup wizard on one or both of the PCs, thats from an option on the left hand column when you are trying to find your other comp in the network connections.
     
  8. Raist

    Raist TS Rookie Topic Starter

    Hi, thanks for your reply. Just renamed both comps on the same workgroup. Still does not work. my uni share folder are gone though from my new laptops. but still i can't see the other folders. I'll try your second recommendation. I heard from someone that I'd have to disable my firewall to be able to share folders. Is this right? I'll let you know what the result is after I try your suggestion!
    Thanks!
     
  9. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,714   +397

    If you are using a firewall other than Windows's built in one, you might have to disable it, or at least figure out what to unblock. But you can be running windows's firewall and still share just fine.
     
  10. Raist

    Raist TS Rookie Topic Starter

    Hi!
    I disabled my zone alarm and ran the network setup wizard. Now i could see the folders from my old laptop but when i clicked on the folder tihs message came up:" \\....\... is not accessible. you might not have the permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. The network path was not found." Does anyone how to solve this? Thanks!!!
     
  11. Raist

    Raist TS Rookie Topic Starter

    Can anyone please help?? Please??
     
  12. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    you cannot disable simple file sharing
    both pc's must now have the same user name and password logged in at time of files sharing
    because 1 of your machines runs on xp home
    xp is buggy nuff home outright bits
    so go to home pc setup user account with the same one thats on the xp pro log in now go to xp pro see if you can access
     
  13. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    On each PC, click Start-Run and type cmd and <enter>.

    Then type ipconfig /all
    One of the items listed (you can scroll up and down) will have all your IP info and things, post this information here for BOTH PCs. So we can just double check that those things are right.

    Also you CAN disable simple file sharing but only on XP Pro.
    Make sure both PCs are logged in as a user with administrative privileges. You can check this by going into Control Panel and into the Users applet. Then check what your user is.

    Next, on the Pro PC, right click your shared folder and choose "sharing and security".
    On the "sharing" tab, of course you have "Share this folder" selected. And give it a name. And select "Maximum allowed". Then click Permissions and check the Full Control is selected for the Everyone group.
    Then click the Security tab. Also click the Everyone group and select Full Control. If the Everyone group doesn't exist, click the Add... button and type it in.

    That should set everything fine for the Pro PC.

    For Home, just share the folder and give it a name. Use the Permissions button, if there, and set Full Control again. But you won't have a "security" tab on the XP Home PC.

    From this point, you should be able to get to your share by typing it into the Run box, or using the address bar in My Computer. You type it like this:

    \\computername\sharename

    This should open your share on the other box. If it does not; if it can't find the computer name, something isn't right still. If it finds the computer name but not the share name, try just typing \\computername and see what that turns up.

    There should be no need to use the Connection Wizard for this. If you set your IPs right, workgroup, sharenames and permissions, and know the computer names, this should all work.

    Hope you get it sorted out soon.

    P.S. If you plan on keeping both PCs, or even adding more, do yourself a HUGE favor and just get a router. It will make your networking so much easier then using crossover.
     
  14. Raist

    Raist TS Rookie Topic Starter

    Hi, thanks very much for your reply!!! heres the IP info from my new computer. I'll post the other one in a minute. I've checked the status of my users, I'm the administrator for both laptops. For your other suggestion, I can't find the permission button on home. For the pro, I can't find the actions you suggested either. I get to these buttons from My network places, right click on the folder, right???
    Again thanks for your help, hopefully it works this time.

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : chris-laptop
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Wireless Network Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Description . . . . . . . . . . . : Intel(R) PRO/Wireless 2200BG Network
    Connection
    Physical Address. . . . . . . . . : 00-12-F0-A1-CF-2A

    Ethernet adapter Local Area Connection 2:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Broadcom 570x Gigabit Integrated Con
    troller
    Physical Address. . . . . . . . . : 00-12-3F-D1-D0-4A
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 192.168.0.1
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.0.2

    PPP adapter {137186FB-A075-47F0-9665-3F6EC314F1E5}:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
    Physical Address. . . . . . . . . : 00-53-45-00-00-00
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 84.160.219.116
    Subnet Mask . . . . . . . . . . . : 255.255.255.255
    Default Gateway . . . . . . . . . : 84.160.219.116
    DNS Servers . . . . . . . . . . . : 217.237.151.161
    217.237.151.33
    NetBIOS over Tcpip. . . . . . . . : Disabled
     
  15. Raist

    Raist TS Rookie Topic Starter

    Hi! this is my IP info from my old laptop (this is the laptop with the XP Pro).
    Thanks!!

    C:\>ipconfig/all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : 'My name'
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Network Bridge (Network Bridge):

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : MAC Bridge Miniport
    Physical Address. . . . . . . . . : F2-D4-55-C9-DD-99
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Autoconfiguration IP Address. . . : 169.254.72.2
    Subnet Mask . . . . . . . . . . . : 255.255.0.0
    Default Gateway . . . . . . . . . :

    PPP adapter {14790E8C-D129-4D7E-AC0A-8EE54A45CAAB}:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
    Physical Address. . . . . . . . . : 00-53-45-00-00-00
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 84.160.208.111
    Subnet Mask . . . . . . . . . . . : 255.255.255.255
    Default Gateway . . . . . . . . . : 84.160.208.111
    DNS Servers . . . . . . . . . . . : 217.237.151.161
    217.237.151.33
    NetBIOS over Tcpip. . . . . . . . : Disabled
     
  16. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    OK, you XP Pro IP configuration is still not right.

    Go into your network connections for the ethernet NIC, into the TCP/IP properties, and set the IP as suggested in the earlier post, to compliment the Home setup. An "autoconfiguration IP" of 169.254.x.x doesn't get you anywhere. Also it should not be on DHCP, but statically asigned, with the right IP, subnet mask, and gateway.

    2ndly, the setting I was talking about, are NOT in Network Places, but in normal My Computer. You right-click and choose these options on the actual folder you want to share. You are working only locally when doing this.
    XP Home probably does not have the Permissions button. And XP Pro won't have the security tab is Simple File Sharing is enabled. Which you turn off by going into View-Folder Options from My Computer.
    At this point you are only setting up the shares and their permissions, not trying to "connect" to anything yet.

    No need to go in Network Places until both PCs have all the proper info and permissions set.

    Lastly, when you change the IP info on Pro, it should look like it does on your home, only with a change in the last octet of the two IPs.

    Hope this sheds a little light on things, I know it can be confusing. If you need me to, I'll take some screen shots of the XP Pro setup. And maybe someone could take some screenshots of setting up on Home.
     
  17. Raist

    Raist TS Rookie Topic Starter

    HI thanks very much again for replying!! haven't had time to try the stuff you told me to do. I'll do them tomorrow and i'll let you know what happens!
     
  18. Raist

    Raist TS Rookie Topic Starter

    Hi, still haven't managed to try your suggestion. Just out of curiosity, how easy/difficult it is to use a router instead of crossover cable? I'm using internet a lot. I know from some friends that using router which functions as a firewall could be limiting internet use. Is this true?
     
  19. patio

    patio TS Maniac Posts: 482

    Not if it is set up properly...even with a router you should be able to have full access to the web.

    patio :cool:
     
  20. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    True. Also depends what kind of Internet you have. A router will let you "split" your Internet up to both PCs, so both PCs can go online at the same time. But this is mostly done with broadband connections such as Cable and DSL. It is more difficult using a hardware router on any dialup connection. And even if you could, getting BOTH PCs using one dialup connection at the same time, WILL limit the connection, as it is half as fast to both PCs.
    For a broadband connection, the split to two PCs you won't even notice.

    The added benefit of a having a firewall helps to stop hackers and bots from getting in your PC, along with easier networking.

    Also note that when using a crossover cable, you have to set all this IP information manually. And if you use your NIC for Internet as well, you have to change your settings back and forth and back and forth. Hardly convenient. With a router, you just set each PC to DHCP, and boom, all your networking and Internet will be functioning at the same time automatically.

    And lastly, should you ever need to transfer files to a 3rd PC, such as a friend or whatever, you can simply plug his PC into your router and you're done. Instead of disconnecting your crossover from your PC, putting it in his, configuring his IPs, shares, workgroup etc...

    And NO, I'm not a router salesman. :)

    P.S. If you ARE on dialup, shame on you, get broadband, it doesn't cost that much more :)
     
  21. Raist

    Raist TS Rookie Topic Starter

    Hi all! just want to thank everyone. Followed Vigilante's advice yesterday and it worked!!! It's not the easiest thing to figure out but well, happy ending at the end. Vigilante: I do have a dsl connection, but since i just bought the crossover cable, I just really wanted to work instead of buying a router. anyway, thanks again everyone!!
     
  22. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Glad to hear, just write down all the IP info so you can change from network to DSL and back again when needed.

    cheers
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...