TechSpot

Corrupt Hard Drive

By feralbyte
Nov 5, 2005
Topic Status:
Not open for further replies.
  1. I have a western digital 320gb (e: ) that I recently purchased and use for storing large files hence its formated to ntfs. And its become corrupt somehow.. its appearantly now raw. I've tried using Active@ Partition Recovery but it says the boot sector is corrupt and cant see anything. I think Bitlord may be responsible for whats happened. I was downloading a file larger than 4gb so I had to save it on my e:. Recently for some unknown reason when bitlord was connected and downloading my modem would drop connection and wouldnt work until I shutdown and then restarted. However not all the files I was downloading were being saved on my 320gb. some where going to my c: drive which is a different harddrive and still working fine.
    Thats the only thing I can come up with, except of course a faulty harddrive. and before anyone suggests my returning it, it was bought while I was in sydney and I'm from adelaide, sort of. So if I can find a way to fix it that'd be good.. Any suggestions on some programs I can use to at least try to recover whats left? Thank you!!
  2. Samstoned

    Samstoned TechSpot Paladin Posts: 2,582

    you can try
    start/run (type in ) cmd
    command prompt type
    cd c:\windows> type in FIXBOOT and press Enter. Then answer "Y"
    theres a lot of file recovery software out there
    some better than others
    I use filescavenger ,but I also have 2 more as backups as they don't all work the same

    how much was on the 320gb drive? it would take over a
    day to run most recovery utilitys
    I have noticed some drive errors when encountering alloction corruption as a jumbled type of overwrite
    or allowing a chkdsk operation to run,sadly, I have noticed chkdsk to cause more errors than fix them,unless I have done the tasking myself
    I don't think any dos utility will get back large files
    any takes on this,anyone?
  3. feralbyte

    feralbyte TS Rookie Topic Starter

    Fixed.. sort of.

    I managed to find what I think caused it. I had it as a slave on the ide port with my dvd burner. Tried swapping it to master and changing cable positions and its working fine now. Altho I wasn't able to get any data back from it. At least my hard drive works. Thanks for the suggestions they were very helpful! :eek:)
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.