could not load OpenGL subsysem

By Moho6842
Oct 25, 2003
  1. Ever since upgrading to windows xp, none of my games work. The startup goes until the screen changes over then jumps out.

    Any suggestions would be greatly appreciated!

    --- Common Initialization ---
    Medal of Honor Allied Assault 1.00 win-x86 Dec 6 2001
    ----- FS_Startup -----
    Current search path:
    C:\PROGRA~1\EAGAME~1\MOHAA\main\Pak5.pk3 (259 files)
    C:\PROGRA~1\EAGAME~1\MOHAA\main\Pak4.pk3 (593 files)
    C:\PROGRA~1\EAGAME~1\MOHAA\main\Pak3.pk3 (669 files)
    C:\PROGRA~1\EAGAME~1\MOHAA\main\Pak2.pk3 (4722 files)
    C:\PROGRA~1\EAGAME~1\MOHAA\main\Pak1.pk3 (772 files)
    C:\PROGRA~1\EAGAME~1\MOHAA\main\Pak0.pk3 (11175 files)

    18190 files in pk3 files
    execing default.cfg
    execing menu.cfg
    execing newconfig.cfg
    Config: unnamedsoldier.cfg
    couldn't exec configs/unnamedsoldier.cfg
    execing safemode.cfg
    couldn't exec localized.cfg
    execing autoexec.cfg
    Unknown command "fov"
    couldn't exec custom.cfg
    ...detecting CPU, found AMD w/ 3DNow!

    ------- Input Initialization -------
    Initializing DirectInput...
    Couldn't set DI coop level
    Falling back to Win32 mouse support...
    ------- Input Initialization Complete ------- 121
    You are now setup for easy mode.
    ----- Client Initialization -----
    Called FadeSound with: 0.000000
    ----- Initializing Renderer ----
    ----- R_Init -----
    Initializing OpenGL subsystem
    ...initializing QGL
    ...calling LoadLibrary( 'C:\WINDOWS\System32\opengl32.dll' ): succeeded
    ...setting mode 3: 640 480 FS
    ...using colorsbits of 16
    ...calling CDS: ok
    ...registered window class
    ...created window@0,0 (640x480)
    Initializing OpenGL driver
    ...getting DC: succeeded
    ...GLW_ChoosePFD( 16, 16, 0 )
    ...35 PFDs found
    ...GLW_ChoosePFD failed
    ...failed to find an appropriate PIXELFORMAT
    ...restoring display settings
    ...WARNING: could not set the given mode (3)
    ...shutting down QGL
    ...unloading OpenGL DLL
    ...assuming '3dfxvgl' is a standalone driver
    ...initializing QGL
    ...WARNING: missing Glide installation, assuming no 3Dfx available
    ...shutting down QGL
    GLW_StartOpenGL() - could not load OpenGL subsystem
  2. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +7

    reinstall your graphics card drivers. download the latest ones from the card manufacturer's website.
  3. Moho6842

    Moho6842 TS Rookie Topic Starter

    thanks phantasm66, that did the trick!
  4. karma_27

    karma_27 TS Rookie

    Open GLSub error messages for Quake Three Arena

    I went to Sci Tech and downloaded GL Direct and installed without any problems. I then went to run Quake 3 and got the following error message

    QUAKE3 caused an invalid page fault in
    module OPENGL32.DLL at 017f:1010c447.
    EAX=66000000 CS=017f EIP=1010c447 EFLGS=00010206
    EBX=00000000 SS=0187 ESP=01109f00 EBP=66000000
    ECX=000081e8 DS=0187 ESI=0081b860 FS=3be7
    EDX=000000e8 ES=0187 EDI=00000081 GS=0000
    Bytes at CS:EIP:
    8b 2c 8e 81 e5 ff ff ff 00 0b e8 89 2c 8e 8b 0d
    Stack dump:
    065b0a80 065b0c5c 101abf80 00000000 00000200 0081b860 00000100 00000100 00000001 00000001 00000029 00000003 00000000 1010cb80 101abf80 065b0a80

    I am running Windows 98. I also tried many of the other solutions...updating drivers and such and nothing has worked thus far. I also am getting an error with my PCI would that have anything to do with it and if so how do I fix that? My computer knowledge isnt what is used to be.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...