TechSpot

Counter strike source just lags up and fps has gone bad

By AlexRuggiero12
Feb 19, 2008
  1. ok well, i turned on css today and i went into a game, i had to get a drink so i went spectate, i then come back and i watched my mate play 1 round, i then joined a team and then i started lagging when i tryed turning side to side and front and back.

    i tryed serveral survers and it keeps happening. it just randomly started happening today, all the times before it was fine and this just happened today.

    Please some1 give me some help, its a really randon thing to happen but i need some help on how to fix it:(

    My system is : Windows vista

    AMD Athlon (tm) 64 X2 duel core processor 5000+ 2.60 GHz

    Memory (RAM) 1022MB

    32-bit orberting system
     
  2. Acclamator

    Acclamator TS Rookie Posts: 261

    Have you reinstalled CS:S?
     
  3. mopar man

    mopar man TechSpot Ambassador Posts: 1,379

    Instead of going directly into Re-installing, you might wanna try defragmenting the game files. Right click the game and go to properties. It should be under one of the tabs. Also, you may wanna try other games and see if it does the same thing.
     
  4. Acclamator

    Acclamator TS Rookie Posts: 261

    What video card do you have?
     
  5. AlexRuggiero12

    AlexRuggiero12 TS Rookie Topic Starter

    well i cant re install, as i bought the game of steam, i dont have thye cd and i dont think its anything wrong with my computer, as i havnt updated anything since i got it and i had css from then and its worked the whole time.
     
  6. AlexRuggiero12

    AlexRuggiero12 TS Rookie Topic Starter

    also, my other games work fine, my cod4 works fine, just css randomly started doing this and my fps drops whe n it was normally 60 now 30-40
     
  7. AlexRuggiero12

    AlexRuggiero12 TS Rookie Topic Starter

    i am now can uninstall and re-install, so i am doing that now, if this doesnt solve the problem what should i do??

    i have also updated my grapshics card, from nvidia.com.

    my graphics card on my PC is GeForce 7600 GS

    plz give me more help. thanks,
     
  8. N3051M

    N3051M TS Evangelist Posts: 2,115

    Check your latency and network connections.. could something be streaming in the bacground using up bandwidth? etc..
    Look at what other programs are running in the background and stop them..
    Check your temps.. especially if you havn't dusted out your pc for a while.. use speedfan or similar to help you check those temps..
     
  9. AlexRuggiero12

    AlexRuggiero12 TS Rookie Topic Starter

    i reinstalled the game and nothing happened, i only have css running and vent.

    i done a virus scan yesterday and there was nothing therre, i tried sevral servers, which are all over the world, i also done a map which was located in the uk (were im from) i have like 20 ping, i move forward and back fine and shoot fine just as i turn left and right, and i chaged my mouse nothing wrong there, i dont know what it is, but my fps haver gone down alot, any way i can get my fps to go back up???
     
  10. mopar man

    mopar man TechSpot Ambassador Posts: 1,379

    Try this,

    I think it may be caused by overheating. Download speedfan (go to techspot's download page and search it). Report the temps here.

    Also, I still say try defragmenting the computer, game files, and running a disk cleanup. If it isn't that, have you tried lowering quality? (out of curiosity).
     
  11. AlexRuggiero12

    AlexRuggiero12 TS Rookie Topic Starter

    ok well im doing the defragmenting now,
    also i told my dad bout the fan, but it doesnt feel hot, do i still need to do the fan scan or if it doesnt feel hot will it be ok?

    also... what does the defragmetning exactly surpose to do?

    also.... the speedfan can not download as a error occured?? so i cant do he speed fan but im still waiting for the defragmenting to finsh, after shall i re try my game?
     
  12. AlexRuggiero12

    AlexRuggiero12 TS Rookie Topic Starter

    ok demfragmenting done, its still is screwed up, i done virus scans aswell, its clear, i dont know what to do, people what do i do??
     
  13. mopar man

    mopar man TechSpot Ambassador Posts: 1,379

    Defragmenting is where it rearranges the files and puts them together..... I don't know aside from taht. Exactly what do you mean when you say it doens't feel hot?
     
  14. Acclamator

    Acclamator TS Rookie Posts: 261

    Actually you can simply back-up your CS:S files using STEAM. Also you can reinstall by just deleting the local game content and downloading it again.
     
  15. AlexRuggiero12

    AlexRuggiero12 TS Rookie Topic Starter

    well i done the defragmenting, it is now working better but still hard to play with.

    i have also uninstalled it and re installed it and nothing happned?

    i dont know what to do i have done everything you guys and gals have said, what else could i do???

    also the speedfan says.... core temp is 44-45 C
     
  16. mopar man

    mopar man TechSpot Ambassador Posts: 1,379

    What about GPU temps?
     
  17. AlexRuggiero12

    AlexRuggiero12 TS Rookie Topic Starter

    how do i find th GPU?

    also.... i now think it might be my graphics card, thats the only thing, the wierd thing is my computer is just over a year old, CSS worked fine till 3 days ago, and i didnt change anything to my PC. My graphics card is a Ge Force 7600 GE.

    Any thing else you could surgest or is my graphics card to crap?
     
  18. KrashdnBurnt

    KrashdnBurnt TS Rookie Posts: 28

    You do know that different maps give different frame rates, right?

    Also, if you're in fire fight amongst 32 ppl, it drastically dwindles
     
  19. Acclamator

    Acclamator TS Rookie Posts: 261

    I know this is a bad thread revival, but we forgot to tell him to fix his rates.

    In console rate 25000; cl_cmdrate 101, cl_updaterate 101
     
  20. mopar man

    mopar man TechSpot Ambassador Posts: 1,379

    Well, Acclamator, if I am not mistaken, that usually is set high enough by default that it doesn't effect anything, really.
    Though, wouldn't it be better to have a higher rate depending on the connection?
     
  21. Acclamator

    Acclamator TS Rookie Posts: 261

    As an intermediate player I can assure you that having those rates make a huge impact on how good you and how easy you can be hit. Obviously CAL and CEVO have certain rates you that you have to abide by. Otherwise people would just do a CMD rate of 1. With it so low they would be nearly impossible to hit.

    Of course if you're in Seattle trying to connect to a Dallas server, lower rates will make you lag less.

    Your game rates really make a big difference, and if you don't have them set correctly you are a noob.
     
  22. mopar man

    mopar man TechSpot Ambassador Posts: 1,379

    Oh, I am sorry, I didn't make myself clear... :/

    I meant that for his problem, which was his FPS, not necessarily server lag. I know that they make a large difference, as I have had to fight people that have crappy rates, which isn't too fun.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...