Crazy Noise....Any Ideas?

By eldorado
Apr 20, 2007
  1. I have a Compaq Presario M2000 laptop, almost 2 years old. Never any problems until about a week ago, when it started making a bizarre noise. The noise ONLY happens when I'm in Internet Explorer, when I change webpages or open a new link. It's a quick, harsh, buzzing noise, and it is silenceable by muting the volume. But I have no idea what causes it, and it's really annoying. Beyond the annoyance factor, I'm worried that it's a harbinger of something worse to come, like the death of my sound card or something. Anyone experienced this?
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    You might try to update some drivers like sound drivers. Are you keeping up with Microsoft's critical updates, using the online Microsoft Update utility?
  3. eldorado

    eldorado TS Rookie Topic Starter

    Thanks for the reply. I am keeping up with the updates, yes. How do I update a sound card? Does that require taking the computer somewhere to be opened up?
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    No, just go to the HP website and search for your Compaq's model under support. Find driver downloads and download and install the sound drivers for your model. Laptops do not have sound cards, they have sound chips the are part of the motherboards. You call this "on-board" sound
  5. Adhmuz

    Adhmuz TechSpot Paladin Posts: 1,618   +494

    Chances are that it IE causing the problems if it was hardware related it would affect a lot more than just IE, what version of IE are you running, have you changed anything, setting, version ect... You can always try to reinstall it or better yet switch to firefox.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...