TechSpot

D-Link DI-514

By lopkiol
Feb 4, 2006
  1. I have a Conexant Titanium ADSL router with 1 ethernet port I use to directly connect to my desktop PC and I go on the internet without problems.
    I also have a D-Link DI-514 wireless router (no modem included) I don't use at the moment and would like to use to go on the internet wireless with my laptop.
    I tried to connect it in series with the Conexant but as I connect it, the led of the ADSL line on the Conexant start to blink (also after reboot).
    The D-Link has 4 ports + 1 WAN port. I tried to use the WAN as well the other ports but nothing changes.
    Can I use the Conexant like a bridge?
    Thanks.
     
  2. Nodsu

    Nodsu TS Rookie Posts: 9,431

    Are you sure the Conexant is not acting as a bridge now? How about trying with straight/crossover cables?

    In theory you disable DHCP on the D-Link, connect it to the router through one of the LAN ports and it works as a switch/AP no problem.
     
  3. lopkiol

    lopkiol TS Rookie Topic Starter

    When you say now what do you mean? If you mean now now I am connected to the internet through the only Conexant. And it act as a router, as I can read in the settings.
    I didn't try with different cables, I have just 2 straight ones. But the manual says all the 5 ports are auto MDI/MDIX.
    Using the D-Link as a switch (with DHCP disabled) shows the same problem, the led winks. ;)
    Do I kill myself?
     
  4. Nodsu

    Nodsu TS Rookie Posts: 9,431

    OK. Just to be sure.. When you connect through the Conexant only, your computer receives an IP address starting with one of: 10, 192 or 172? If that is not the case, then the Conexant thing is acting as a bridge.

    Is the DSL light blinking bad? I mean are you unable to establish a connection later on? Did you disable DHCP in the D-Link? Is the D-Link's local IP address different from the Conexant's? The Conexant may be panicing and rebooting because it finds a competing DHCP server or an IP address conflict..

    Also, all these "auto" things in ethernetworking are not perfect and may fail. Always a good idea to set link speed, duplex, MDI(-X) manually.
     
  5. lopkiol

    lopkiol TS Rookie Topic Starter

    Yes, if I set DHCP on the Conexant I receive on the computer the IP 192.168.1.X (the subnet is 255.255.255.0). Otherwise I need to set it manually on the same subnet because the IP on the LAN side of the Conexant is by default 192.168.1.1.
    On the WAN side I AUTOMATICALLY receive the IP from the ISP: 86.111.YYY.YY, mask 255.255.255.255 (strange subnet, isn't it?), gateway 86.111.ZZZ.ZZ and encapsulation protocol PPPoA. And the connection works fine.
    On the other hand this does NOT happen when I plug the ethernet cable coming from the Conexant in to the WAN port of the D-Link. Moreover, if I go on the PPP configuration page on the Conexant, I see the "Oper. Status" is "Link Down". In this case there are these IPs: 0.0.0.0, mask 0.0.0.0 and gateway 0.0.0.0. I tried to change them manually but there is no way to do it.
    I disabled DHCP on the D-Link. But I also put it on a different subnet, his LAN IP is 192.168.0.1 (255.255.255.0) so I can enable it (moreover on the settings I read the DHCP of the D-Link acts only on his LAN).
    But the line light does not stop blinking. :dead:
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.