D-Link DI-624+ not assigning IP numbers for wireless devices

By Gordon Reid
Aug 16, 2005
Topic Status:
Not open for further replies.
  1. I have recently purchased a D-Link DI-624+ wireless broadband router.
    It has 4 fast eithernet ports and wireless at 802.11g.

    Followed the instructions and my 3 PC's all get a DHCP assigned ip address, they are all runnning Windows XP.

    Went to set up my laptop and encountered the following problem when the device should be issueing an ip address of 192.168.0.104 after around 30 seconds all I get is an IP of 169.254.211.20 and subnet of 255.255.0.0.

    I've tried to do it manually, and all the usual ipconfig /release /renew stuff but it still come back after around 30 seconds with the above ip address.

    I've found on the web a reg fix of:
    The reason you get the 169.254.XXX.XXX address is because Windows will apply that address as a default if it does not receive a DHCP assignment. It has been my experience that this happens before a DHCP connection is made sometimes putting you on the wrong subnet. The fix is easy ... defeat the automatic IP assignemnt feature in XP.

    Do the following: (from the Microsoft website)

    With REGEDIT open
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\Tcpip\Parameters.
    Click on the parameters folder
    Click Edit
    Click New and then click DWORD Value
    Enter the following: IPAutoconfigurationEnabled
    Righ click the new entry and then click Modify
    Verify that the value is zero or make it 0.
    Exit Registry editor and reboot.
    The zero value disables the auto IP assign feature. To re-enable either delete the DWORD entry or change the value to 1.

    However I can connect to the person 3 doors down the streets wireless access point without making any changes to my laptop.

    Is there something in the D-Link that should be changed - I'm lthink is there an equivalent of a port fast setting that you get on Cisco switches (if this was not set the ports took 30 seconds to reconfigure and apple mac's would time out and fail to get a network connection) and I wonder if this is whats happening to the laptop its timing out and taking the 169.... range as default?

    Gordon
  2. StormBringer

    StormBringer Newcomer, in training Posts: 2,871

    check the firmware version on the di624, if it isn't the latest, update it, then try disabling SuperG with Turbo mode. This is only useful if you have a dlink SuperG card, and can sometimes keep other cards that don't support the superg feature from working properly with that router.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.