TechSpot

Daily BSOD and PC reboots

By terry5880
Jan 20, 2011
Post New Reply
  1. hi had new mb fitted 3 weeks ago but they put old ram etc back in, my pc keeps rebboting and giving recovered from serious error , i since turned off rebbot automatically and the stop code etc i get are as follows
    DRIVER_IRQL_NOT)_LESS_OR_EQUAL
    STOP 0x0000000D1 (0xAA70C438,0x00000002,0x00000008,0xAA70c438
    viahduaa.sys -address AA70C438 bass at AA60C000, date stamp 4a03a575
    beggining dump of pysical memory. etc
    pc does it alot but mainly does it when trying to play football manager2011.
    im on win pro ser pack 3 512ram
  2. Route44

    Route44 TechSpot Ambassador Posts: 12,142   +31

    FYI the mods will move this to the appropriate BSOD forum.

    0xD1 errors are usually caused by faulty drivers. In this case it is viahduaa.sys which is a VIA High Definition Audio Function Driver belonging to your onboard audio.

    Find the exact make and model of your motherboard, go to manufacture's website, find your model there and install the latest audio drivers for said board.
  3. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 527

    hi thank you i been told so many times its the ram. sorry if posted in wrong section the mb is P5KPL-AM-EPU
  4. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 527

    topic

    hi sorry people . once again pc reboots and alot of the time it resets the settings on some app i use like win mx etc. i tried to put mem test on to disc but it dont boot from start so done mem test after closing all programs apps etc and left it running for 30 min but 0 errors as above i seem to have a audio driver error im no gd at what site to go to etc some one pls help thanks
  5. Route44

    Route44 TechSpot Ambassador Posts: 12,142   +31

    often your DVD drive must be First bootable in the BIOS for Memtest to engage. Follow these steps because 30 minutes is not enough time.

    Step1 - Let it run for a LONG time. The rule is a minimum of 7 Passes; the more Passes after 7 so much the better. The only exception is if you start getting errors before 7 Passes then you can skip to Step 2.

    There are 8 individual tests per Pass. Many people will start this test before going to bed and check it the next day.

    If you have errors you have corrupted memory and it needs to be replaced.

    Step 2 – Because of errors you need to run this test per stick of RAM. Take out one and run the test. Then take that one out and put the other in and run the test. If you start getting errors before 7 Passes you know that stick is corrupted and you don’t need to run the test any further on that stick.


    * Get back to us with the results.


    *** If Memtest shows no errors then find the voltage specs of your RAM and compare it to the voltage setting in your BIOS. Do they match? How about the timings?

    *** Did you update your onboard audio drivers?
  6. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 527

    above topic

    hi m8 ty for this help so much i dont know how to do most of these things but do try. i think i have installed latest driver as got right to 100% pc rebooted again. also memtest i cant seem to get it to disc and the reboot thing u said soi clicked on file it opened and told me to close all programs then i ran it but it only come up in % at bottom went over 2000% is tht right if soo ill do it again and leave it running till morning
  7. Route44

    Route44 TechSpot Ambassador Posts: 12,142   +31

    I read all your dumps from your other post. All errors are the same 0xD1 that are usually caused by faulty drivers. In all five files the same viahduaa.sys which is a VIA High Definition Audio Function Driver belonging to your onboard audio is cited as your cause.

    This driver must be updated.

    Your motherboard make and model is an Asus P5KPL-AM-EPU. Go to Asus' website, find your model there and install the latest audio drivers for your board.
  8. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 527

    topic above

    thank you so much for our help route44 . i did go there and think i found the driver but it doesnt say update it just had 3 diff drivers there i think i will get there in the end
  9. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 527

    topic above

    hi sorry people.. well i have tried loads now to update the drivers to no avail. been to asus where nothing there . clicked on hd audio where it takes me to site. it doesnt have xp pro there just xp or xp64bit . tried both gone to latest updates but to no avail please please help
  10. Route44

    Route44 TechSpot Ambassador Posts: 12,142   +31

    What OS did your system originally come with?
  11. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 527

    above topic

    bought about 6 yrs ago but reformatted so many times over the yrs with diff os . its now win pro but 1st ever had win xp home edition
     
  12. Route44

    Route44 TechSpot Ambassador Posts: 12,142   +31

    The fact that it is 6 years old is most likely why there isn't any new updates. What they have posted on their site is probably the latest and last for your system.
  13. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 527

    hi

    but its a brand new mb and the via hd audio deck came with mb they only put it in 3 to 4 weeks ago mate
  14. Route44

    Route44 TechSpot Ambassador Posts: 12,142   +31

    What is the make of the motherboard and model #.
  15. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 527

    as above

    hi it is asus P5KPL-AM-EPU when they put it in it came with the via hd audio deck etc thanks for your help route44 much appreciated
  16. Route44

    Route44 TechSpot Ambassador Posts: 12,142   +31

    Okay, understand now. When you went to Asus' website and looked up your current motherboard what were the dates on their latest updates for your board?
  17. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 527

    ?

    im not sure m8 i was just going to the drop down bits and adding info let me look now
  18. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 527

    ?

    ok i go to website then d/l then on left put in mb but nothing happens then on right i click on wizard but nothing happens
  19. Route44

    Route44 TechSpot Ambassador Posts: 12,142   +31

    They should automatically install once you click on them.
  20. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 527

    ?

    hi m8 if u look on website click download then on left had drop down but nothing happens then to right there is a wizrd thing to help but i click it and nothing happens no pop up etc . then on right is another 3 drop down bits but not sure what to click on as in sound card mine is not listed or in mb drop down ?
  21. Route44

    Route44 TechSpot Ambassador Posts: 12,142   +31

    Can you save these updates to your desktop?
  22. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 527

    ?

    yea m8 i think i have latest installed as it says 3.0 which is what i got and its not from asus website via hdaudio deck has its own website as i just found it by clicking on the icon in my task bar so maybe conflicting driver somewhere . i will take it bk to the shop monday and let them sort it ty for your help mate


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.