TechSpot

defrag will not start !

By tomrca
Dec 31, 2006
  1. done a defrag a couple of weeks ago, worked well. today checking the driives, i got a message saying "Disk fragmenter could not start". i have done a system restore, butit remains the same..
    i have run an hjt and its clean, although i will post an hjt to be sure.
     
  2. gbhall

    gbhall TechSpot Chancellor Posts: 2,425   +77

    have you tried it in safe mode?
     
  3. jobeard

    jobeard TS Ambassador Posts: 9,351   +622

    requires service to be started

    see CP->admin->services
     
  4. tomrca

    tomrca TS Rookie Topic Starter Posts: 1,000

    thanks for your reply. i have looked through services, but i am unable to find anything referring to disc defragmenter. could the service name be different from what i am looking for?
     
  5. Rik

    Rik Banned Posts: 3,814

    What happens if you try start, run, dfrg.msc??
     
  6. tomrca

    tomrca TS Rookie Topic Starter Posts: 1,000

    hi rik. the response is the same. the programme opens, but will not analyse or defrag
     
  7. Rik

    Rik Banned Posts: 3,814

    Have a look in windows\ system32 and checkout dfrg.msc. As an example im using xp pro sp2 and my dfrg.msc is 41k.
     
  8. tomrca

    tomrca TS Rookie Topic Starter Posts: 1,000

    40.4 KB (41,397 bytes)
     
  9. Rik

    Rik Banned Posts: 3,814

    How about seeing if you can extract a new copy of dfrg.msc from your windows cd. I can't test it myself as i have lent my windows cd to a friend that managed to scratch his own one.

    If that's not possible then visit microsoft n see what they say.
     
  10. tomrca

    tomrca TS Rookie Topic Starter Posts: 1,000

    40.4 KB (41,397 bytes) there is nothing that exactly matches "dfrg.msc"
     
  11. tomrca

    tomrca TS Rookie Topic Starter Posts: 1,000

    looks like i may need to run a repair install.
     
  12. Rik

    Rik Banned Posts: 3,814

    Let me know if my email helps you out or not.:)
     
  13. tomrca

    tomrca TS Rookie Topic Starter Posts: 1,000

    fixed it!! the page file was switched off, dont ask me how though, that will remains a mystery..
     
  14. Rik

    Rik Banned Posts: 3,814

    Glad you sorted it!:) That's one for the memmory banks for possible future use!!
     
  15. jobeard

    jobeard TS Ambassador Posts: 9,351   +622

    bougs :(

    oops! totally bogus information, sorry. Speed Disk Service belongs to :( Norton :(
     
  16. wasasa66

    wasasa66 TS Rookie Posts: 23

    what page file are you talking about??

    My computer wont defrag and I'ts reaching Critical Mass.

    Please help
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...