Desperatly Need Help With My Multimedia Controller!

By cheekytrolly
Sep 30, 2005
  1. Someone please help me- when I run full screen games like The Sims 2 and GunZ Online, my sound goes all distorted and keeps on jolting and cutting in and out!

    I’m running a 2.4 GHZ Celeron with a Creative SB AudioPCI 64V Sound Card on (on Windows XP)

    I looked in my device manager and took the screenshot below, noticing that my Multimedia Audio Controller had the yellow question mark and exclamation mark next to it, so I removed it only to have it be replaced when I restarted and it asks me for the driver CD ROM or floppy so it can install itself- but I don’t have any driver for it and I don’t know where to get one!


    I tried downloading a driver for my sound card from the creative website but I got an error message when I tried to run the EXE file saying that the system could detect no Sound Blaster card installed!

    Then, I phoned the local PC store and they told me that the Multimedia Audio Controller was confecting with my sound card and I need to remove it in the BIOS but this cant be right as I've had my computer for over a year and I've never had this problem before, my sound only started going strange this week!

    Please someone- HELP ME! I just want my sound to run smoothly and normally in my games. It’s ridiculous because my sound works in some games and not others!

    Please reply to this forum ASAP or give me an email- at

    Thanks very much in advance

    Andrew Underwood

  2. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    I'm not sure the device is related to your problem. The Creative soundcard is listed without any problems in the device manager screen capture you have provided.

    Sims2 and Gunz Online are very, very system dependent games- so if your system is starting to run sluggishly or has any virus/trojans, or you have too much running on that poor Celeron, this could cause the stuttering or problems with sound you describe.

    The advice given though is good advice. If you have an onboard soundcard you are not using, it is wise to disable it in the BIOS or with a jumper. If neither your BIOS nor a jumper exists, simple use the drop-down at the bottom seen in your screen capture to select "Do not use this device (disable)" and reboot. Windows will not try to allocate any resources to it in this way. It's still 10x better to "truly" disable it in hardware though.

    I'd recommend trying the following for a test to see if it improves your sound problems:
    1) Run a DEFRAG on all your disks. Fragmented disks can cause your issue.
    2) Before launching one of the games with the problem, open the Task Manager and kill any unneeded processes. Your systray appears to have much running as well.. kill any of these (right-click/exit) after expanding.. and run the game to see if this also helps.
  3. cheekytrolly

    cheekytrolly TS Rookie Topic Starter

    Fistly, thank you ever so much Sharkfood for you quick reply and helpfull answers and solutions to my questions! Please continue to help me, I have a few more continued questions:

    I've been playing these games regually for a long time and my 768mb of ram lets them run smoothly, yet all of a sudden the sound has gone strange! I also have the latest virus and spyware protected and only visit safe websites so I dont think any sort of virus is affecting the audio...?

    As for the defrag, I'll do one tonight and let you know tomorrow if it helps or not.

    I couldnt find the 'drop-down at the bottom seen in your screen capture' to disable the device, but I simpley right clicked and pressed un-install to get it out of the Device Manager, yet when I rebooted it came up with the little yellow banner saying Windows has detected new hardware and it appeared in the Device Manager again with the little exclamation mark next to it as eforehand! :mad: (If all else fails, I'l take the computer down to the shop to get them to do the BIOS trick but that will set me back $45 + GST)

    Lastly, I tried closing all the un-needed process in the 'systray' that were running in the background and although it helped with the speed of the game, it didnt effect the audio.

    What I find strage is that other high power games such as GTA San Andreas and Unreal Tournment 04 run the audio fine, it's just the sims 2 and gunz im having trouble with!

    Again, thanks very much for your comments and please continue to help me! I really appreciate it :)

  4. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    The performance of your system can decrease over time. The disk drives become fragmented, the pagefile/swap file becomes fragmented and then your computer will need much, much CPU/IO to do the same things.

    You can also optimize your pagefile if you only have 768mb of memory. The pagefile is a big file that Windows uses to simulate extra memory. It will page things not in use to the pagefile. By default, this pagefile is designed to shrink and grow as needed, but this in turn, fragments the disk more.. and fragments the pagefile! Once fragmented, quick pagefile operations can take much, much more time and slow your system down- creating pauses and stutters in sound from the extra overhead.

    To optimize the pagefile:
    1- Right-Click "My Computer" and select Properties.
    2- Go the the Advanced Tab and click "Settings" in the Performance group near the top.
    3- In the next window, click the "Advanced" tab at the top.. then click "Change" at the bottom under the "Virtual Memory".
    4- The next screen lists any drives/partitions you have at the top and what pagefile settings are. Click on each/any drive at the top that has pagefile sizes listed next to it and click "No paging file" and hit "Set". Keep doing this until all the drives listed at the top have no paging file size next to them.
    5- Click OK at the bottom and keep clicking OK to each window until it prompts you that you must restart your system. GO ahead and restart.
    6- After restart, DEFRAG all your drives once more.. do not launch any games or software.. just defrag.
    7- After your drive(s) are defragged completely, go back into My Computer/Properties/ Advanced, etc.etc. where you disabled the pagefile.
    8- This time, click on the drive and click "Custom Size". Set the
    Initial size (MB): 1536
    Maximum size (MB): 1536
    and click "Set". It should show up at the top as 1536-1536 next to the drive.

    9- Click OK at the bottom and keep clicking OK to exit. It may or may not ask you to reboot the system. I'd recommend restarting anyways. The boot may take a few moments longer than usual this first time.

    What you have done here is create a static/unchanging pagefile on freshly defragmented disk space. This prevents the pagefile from ever becoming fragmented again.. and it will also never grow/shrink slowing performance.

    In your screenshot above, look at the bottom of the device window you have up. It has the area below that says "Use this device (enable)". Click the little triangle/arrow and find the "Do not use this device (disable)" and reboot.

    If you simply uninstall or remove the device, as you experienced, Windows will just refind it and try to add it again. You have to flag it as (disabled) to tell Windows to ignore it.

    This would also lead me to believe your problem is fragmented disk and fragmented page file. Sims2 and Gunz use a ton of memory and have probably been using the pagefile like crazy in the past. Just now the disks and pagefile are very, very fragmented and need to be cleared up/unfragmented.

    Good luck!
  5. blue_dragon

    blue_dragon TS Rookie Posts: 190

    umm i skimmed thru it
    try to uninstall again
    when the yellow balloon detects the hardware again, choose the option
    "install driver from location (recommended)" or something like that
    if its unsucessful then restart
    when u have booted again go to
    contorl panel-->audio devices---> click the "advanced" button under "speaker settings"
    then go to "performnace" tab
    lower the hardware acceleration to "none"
    and the other slider to "good" instead of "best"

    hit ok until all the audio properties windoiws are gone
    try the game
  6. cheekytrolly

    cheekytrolly TS Rookie Topic Starter

    Thanks guys, I logged onto this forum as soon as I woke up this morning after defragging my PC overnight. I tried playing the sims 2, and the sound worked fine in all the loading screens untill I got into the main play mode in the game :mad: Anyway, I read blue_dragon's advice and went to alter my speaker settings only to find that hardware acceleration was already set to 'none' so all I had to do was change the slider below it to 'good' I tried the game again- with the same result as before.

    As for sharkfoods instructions, I will carefully go through these this evening and again defragment it overnight like you said and report on the changes in the morning, sorry to keep you waiting but its the weekend and I wanna surf the net and play other games (with normal sound) for the day.

    Thank you very very very much for all your help guys, and please check back here tomorrow morning! :wave:

  7. cheekytrolly

    cheekytrolly TS Rookie Topic Starter

    guess what people? I got the sound on Gunz working! All I had to do was go into the sound settings and tick the following two options:

    3D Sound Retroflexction Left-Right
    Hardware Mixing Support

    (see screenshot below)
    Now im wondering- is it possible to do that for the Sims 2, prehaps the answer is simpeler than we all thought???

    The second part of my post is for Sharkfood:
    Before I went to bed last night, I follwed your instructions right up to number 4, where you said 'click no paging file and hit set'

    I got this message up and I thought it would be safe to click 'OK' and just get onto to it, but I'd thought I would check with you first, heres another screenshot displaying the message:

    Please could you advise me on what to do next, I'm really really appeaciating your help, Thank you so much.

  8. cheekytrolly

    cheekytrolly TS Rookie Topic Starter

    just a little bit more to addon,
    I went on the sims 2, to see if I could change any sound settings like Gunz but the options werevery basic and didnt help. I also wanted to see if the sound had improved at all, but the sound is still all jerky and stuttery. I made two recordings for you. to see for yourself

    Recording 1:
    (This is the distorted start up music which plays while it loads)

    Recording 2:
    (This is meant to be a sim answering a ringing phone)

    When I pasued the game for a long time then unpaused it, the sound worked fine for about 80-100 seconds then went all jerky again. IHope this helps, Thanks again for eveything.

  9. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    Yes, you want to say it's okay/continue anyway. Disabling all page files is just for a single reboot + defrag. That's why it's important to simply reboot, defrag, then reset a static pagefile.
  10. cheekytrolly

    cheekytrolly TS Rookie Topic Starter

    Hi sharkfood.
    I degragged my comp- only took 1 hour! The I changed the pagefile size like you said, but no change on my game still :( I'm gonna go into the BIOS and delete my onboard AC'97 sound device, see if that makes a differance.

    Now my pagefile is smaller, what effect will it have on my computer?


  11. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    Howdy cheeky!

    It's not really "smaller"- it's actually allocating 1536mb *always* whereas if you look at your above it was only allocating about 1100mb, with the potential to grow up to 2304mb. That shrink/grow from 1100+ to whatever it peaks out to is what fragments your HD as that pagefile would shrink and grow. That also stumbles performance as the file is constantly changing size.

    Now it's capped at 1536.. period. It wont shrink/grow and this improves performance. You should notice much smoother launching/closing applications and better game performance. A 768MB system will be hard-pressed to use more than 1536mb of pagefile. If you have insufficient pagefile + memory, you'll get "Out of memory" or "Unable to allocate memory" errors in games. I doubt you get this with 768MB of RAM + 1.5 gig of pagefile/virtual. Most games only peg about 900MB-1100MB (between physical ram and virtual). Only if you're an avid Photoshop user or other massive graphics editing or video editing software would >1536mb pagefile be a major concern.. and if you do exceed that, I'd still say bump up RAM vs. pagefile to compensate. If you're paging more than 1.5gig to disk for virtual memory, this will be very, very slow.

    As far as the stutters go, we're still encountering some issue. Can you probe your IDE controllers? In the device manager look at the primary/secondary and see if they have DMA listed in any of the tabs. It's possible DMA isn't working correctly on your HD controllers/drives. This would be the next step to check for stuttery/bad sound. This is, of course, after you've gotten the old/on-board sound rectified- either through BIOS, jumper or disabling in the Device Manager so it will return it's resources to Windows.

    Good luck!
  12. cheekytrolly

    cheekytrolly TS Rookie Topic Starter

    Hi again sharkfood, thanks for your quick response.

    I went into the BIOS and disabled my onboard AC'97 sound device, but it hasnt made any differance in the sims 2, yet it has removed the Multimedia Audio Device from the Device Manager which 1 of my 2 proplems solved :grinthumb

    As for your pagefile explaination, I understand it now and id like to thank you very much for explaining it too me and improving my PC's preformance! :grinthumb

    As for the stuttering, I'm beginning to wonder if it is my disk that has been scratched or something and mabey I should download a crack for it. I downloaded the 1.1 patch from the offical sims2 website but it had an error installing.

    I'm in the device manager now but I'm not sure what to look for when you mentioned:
    Could you please tell me what to do here?

    So much for 'amatuer pc guru' :haha:

    Thank you again for all your help and the time you have spent helping me, I really appreciate it and can't thank you enough,

  13. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    As that's a Celeron/Intel based system, it likely has an Intel Chipset. (or it could be SiS or VIA.. hoping for Intel!)

    Have a look in the Device Manager under IDE ATA/ATAPI CONTROLLERS and with any luck, there should be three devices:
    -Chipset controller

    I'd check Properties on both the Primary and Secondary and see if in the Property sheet, you can find any reference to DMA/DMA modes on those controllers. DMA allows hard disk controllers to perform IO without hogging the CPU/CPU bus. Without DMA working, you can encounter the issue you are reporting.

    An example of an Intel based systems Primary IDE Controllers Property Sheet WITH DMA working correctly:

    As you can see, in the Property sheet, it lists DMA modes for the devices on it. CDROMS and DVD drives are okay if they don't have DMA. Not all of them support DMA.. But Harddisks should most definately.

    This may lead us to the next step to fixing your problem if you have no DMA or need DMA/correct IDE drivers for your system.
  14. cheekytrolly

    cheekytrolly TS Rookie Topic Starter

    Hi sharkfood,
    I followed your intructions like you said and DMA was listed in the primary channel but not secondary- is this right or wrong?
    I have attached a screenshot below, thanks, andrew.

  15. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    That looks great cheekytrolly.. the PIO mode device is likely your CD/DVD drive. Those are usually non-DMA. Your main primary IS DMA, so this is likely not the cause.

    So.. Drive DMA is enabled, page file is static and drives are defragged. We have more things to check..

    Check your BIOS and look for a setting for PCI Latency. Try higher and lower values for this. Try 32, 64, 96 & 128 settings. If you do not have PCI Latency, there are 3rd party tools to adjust this in Windows.... but I'm hoping you have this adjustment in there.

    EDIT- If your BIOS has no PCI Latency setting, this tool can do the job:

    BIOS adjustment is HIGHLY recommended though, so prefer this if your BIOS has such setting (most modern BIOS's do).
  16. cheekytrolly

    cheekytrolly TS Rookie Topic Starter

    Hi sharkfood,
    I went into the BIOS and in advanced, I found an option called PCIPnP and I found an option 'PCI Latency Timer' and it had 8 options as follows:


    It was set on 32 for default, so I tried each one in turn, editing the BIOS then running the Sims 2, turning my PC off, turning it on, editing the BIOS, running the game, turning it off, etc

    Sometimes the music ran normal for a while, but then got distrorted when it got to the main game screen.

    Anyway, what should I set it onto default for???
    And do you have anymore suggestions on how to improve the sound???

    Thanks again sharkfood,
  17. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    There is no real "guideline" for a default PCI Latency adjustment. PCI Latency is simply how many MAX PCI clocks a device is allowed the bus prior to yielding it to another device.

    Some combinations of hardware (certain network cards, sound cards and AGP/PCI videocards) may "hog the PCI bus" or need more cycles in order to perform their duty without hitches/problems. Finding the smoothest value specific to your hardware is the trick here. SoundBlaster PCI systems generally can run a bit better at 64 or 96 PCI clocks if they have certain AGP Videocards. This can help reduce sound sputter/stutter as well as sometimes even positively impact videocard performance (less stutters/hitches in framerate).

    Last but not least, you should also explore software issues with what you may have running while playing the game. Any applications in the systray (bottom right), try right-clicking and selecting "Exit" or "Close" prior to playing to see if it helps. For a test, you may wish to totally uninstall any anti-virus or firewall/security software- simply disabling them may not help as even disabled, they may be strobing/activating. McAfee tools are well known to have stutter issues on some systems, even when disabled. etc.etc. Task Manager can also be inspected for any suspect processes that may be contributing to the problem.

    Good luck!
  18. cheekytrolly

    cheekytrolly TS Rookie Topic Starter

    thanks for all your help sharkfood- I guess I'll just keep trying to fix this untill I find a soloution, and when I do I'll post it here!

    In the meantime, If anyone else can help me, please post here in this forum,


Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...