Device Installer Error Geforce 4 mx

By Zack Attack
Mar 1, 2005
Topic Status:
Not open for further replies.
  1. Hi

    I am new here. I not the best at computers so try to bare with me.

    I have a geforce mx 440 I just had it put in to my computer
    which is a CPU:3.06 GHz and 1gig of ram its new.

    now after putting in the card I got the software which is a disk that came with it and loaded it. I clicked on display drivers and got the following error message "Device Installer error" windows cannot load the installer for display. Contact your hardware vender for assistance.

    thats as far as I get what do I do know I cant play any of my games that I could before like the sims 2.

    I have already tried installing the new drivers but I get the same error message Does it have some thing to do with my device manager.
    Edit/Delete Message
  2. shadow_29

    shadow_29 Newcomer, in training Posts: 252

    hi zack

    first of all welcome to techspot :wave:

    now as for your problem,first tell me if you had another graphic card installed on the system or onboard video before you put mx440 in.the device installer error could be because of a number of things.is thecard agp based,if yes than install the GART driver that came with the mobo,remove any traces of your old card if you had one,reboot let windows detect the card and load an older version of the drivers like 30.82 or 45.32 they should be named in your cd that came with the graphic card,reboot and they should be working.if not than post back.
  3. Zack Attack

    Zack Attack Newcomer, in training Topic Starter

    First of all thanks alot for reading my post

    The card is 4xAGP interface. (not the best with computer so I dont know what the GART is or the Mobo)

    I dont think I had a video card before because when I put in the card the slot was empty for it so nothing was there. I had no other drivers installed in the device manager either. Then again im not sure because I was still able to run games like the sims so I dont know. On the cd that came with geforce mx 440 A-G446 (V31.40).
  4. Rockfan1815

    Rockfan1815 Newcomer, in training Posts: 59

    Well then you have an integrated chipset(graphics). Did you Disable the integrated or uninstall the drivers.
  5. Rockfan1815

    Rockfan1815 Newcomer, in training Posts: 59

    Also Do you have any idea what chipset is in your computer
  6. Zack Attack

    Zack Attack Newcomer, in training Topic Starter

    no I didnt i didnt disable any thing I dont know were or if I had other drivers for the chipset I had. Im not sure what chip set is in this computer how can I check?
  7. Zack Attack

    Zack Attack Newcomer, in training Topic Starter

    I found out what kind of card it is it's a 64 MB S3 SAVAGE 4 GRAPHICS SHARED ACCELERATOR but im not sure were to find it or disable it though Because I see no drivers for it.
  8. Zack Attack

    Zack Attack Newcomer, in training Topic Starter

    How do I install the Gart that came with the mobo? wait what is and were is the mobo lol
  9. Rockfan1815

    Rockfan1815 Newcomer, in training Posts: 59

    go to control panel, switch to classic view, click on system, click on hardware tab, then device manager and display adapters and click on the graphics listed under it and click the driver tab and look at the bottom of the window and see if it says disable. thats what I did when I was trying a graphics card in my computer. I first diabled the integrated, installed the card and ran the program that came with the graphics card. this might help, i'm not sure but I hope it does. Also check the bios, mabye something has to be changed, don't change anything though is you don't know what to do. Also if your not kidding around the Mobo is the mother board.
  10. Zack Attack

    Zack Attack Newcomer, in training Topic Starter

    Alright an update in my device manager under display adapters theres only one option it says Video controller (VGA Compatable) when i click on it i get the same stupid error. now i cant install any thing in there because i get the error (windows can not load installer for display) i cant udate uninstall NOTHING
    is this the nivida drivers or is this my old drivers?? under location it says Pci bus 1, divice 0 function 0 is there im srorry this is so confusing all i want to do is get my games running like before.
  11. Rockfan1815

    Rockfan1815 Newcomer, in training Posts: 59

    Pci bus 1 is just a different way of saying AGP or accerated graphics port. If I were you, I would just wipe the hard drive and start fresh, but only if you have all the cd's that came with your computer like windows and restore cd's. If you don't have those cs's and you set a system restore point before you started to get this error, than you can run the system restore and have your computer back the way it was before this mess. Also, do you know if your mother board supports your graphics.
  12. Rockfan1815

    Rockfan1815 Newcomer, in training Posts: 59

    also, if this don't work, my advice is to call the people who makes your computer and graphics card, they should beable to help because they know more about their products then we would
  13. Zack Attack

    Zack Attack Newcomer, in training Topic Starter

    but were it says Video controller (VGA compatable) in dervice manager do all systems have that? or that just came when I installed the card in my system?
     
  14. Rockfan1815

    Rockfan1815 Newcomer, in training Posts: 59

    I actually have no clue what you mean, I looked on my computer but I didn't see anything like that, that could also be because I have a different integrated video chipset. Spend a couple dollars and take it to a professional at a computer store or take it to the geek squad at best buy. but first try starting fresh unless you have important stuff on your computer that you don't want to delete. Basically something got screwed up, something that you didn't change before you put in the card.
  15. wajvonk

    wajvonk Newcomer, in training

    The solution

    Had the same problem and here is the solution that worked for me.
    Find "desk.cpl" in c:\windows\system32\dll cache and copy it to system32.
    :angel:
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.