TechSpot

Device Manager EMPTY??!! USB ports u/s??

By Lovepeaceguru
Jan 9, 2006
  1. I'm not sure if this is the right forum in which to post this question but please, please, please can somebody help?

    After trying to install a new printer, discovering that my USB ports won't detect anything, My Computer and IE suddenly taking ages to start, everything hanging everywhere, I find that my Device Manager window is completely empty!!!!!!

    PnUP is activated.

    Can anyone help????

    I've tried:

    is PunP working?
    Tried Apropos fix
    Tried correcting registry entries in ENUM permissions

    Nothing works.

    Also system was hanging on startups and shutdowns, sometimes needing the big switch to get out of it. Now you can click on IE or My Computer or Control Panel and it takes ages for them to load. Usually I find myself with about five instances of each all loading at once.

    Frequently web links wont work. The only thing I can do is avoid a left click - use right clicks to save shortcut and then paste it into address bar.

    Please can somebody help. My kingdom for a horse!

    Thx Thx Thx in advance


    Lovepeaceguru

    My System Information

    3.4GHz P4
    1024 MB
    750 MB disk space on 2 drives
    3 x DVD writers
    8MB Bulldog connection through LAN to router
     
  2. Lovepeaceguru

    Lovepeaceguru TS Rookie Topic Starter

    Success!!! Wel partial successs anyway!

    I have a partial resolution to my problem!

    Thanks to everyone who offered help.

    First option was check that PuNP was started - OK. Later I discovered that Universal PuNP must NOT be started!

    Second option was Aproposfix which I assume is to get rid of some specific spyware/adware/malware.

    Third was I tried editing some permissions in the registry but I didn't really understand what I was doing.

    Fourth was I ran sfc/scannow - whatever that is!

    Also system was hanging on startups and shutdowns, sometimes needing the big switch to get out of it. Now you can click on IE or My Computer or Control Panel and it takes ages for them to load. Usually I find myself with about five instances of each all loading at once.

    Frequently web links won't work. The only thing I can do is avoid a left click - use right clicks to save shortcut and then paste it into address bar. I have tpo switch back and forth betwen web browsers using teh Task Manager. OIften the Task Manager itself freezes with the button still "pressed down".

    I've also been using my SpeedUpMyPC utility which allows you to give CPU priority to a particular window. A combination of this, Task Manager and a hell of a lot of patience just about keeps me going

    Oh, and I updated all my chipset drivers along the way.

    MY DEVICE MANAGER WINDOW IS NOW FULLY POPULATED!!!!!

    Oh joy! The printer is working too. The solution? It was to do with permissions. I had to spend a lot more time and give a lot more thought to it. (I still don't understand it properly). It's in HKEY Local Machine "Enum"
    whatever that means?

    So many thanks to the Annoyances.org forum which first gave me the idea for that fix.

    BUT!!

    Some things are better like loading IE or My Computer or Control Panel. They're still slow though and I can still find myself with loads more browser windows open that I need. On IE though browsing still suffers froim the same problem. Links won't work. I have to copy shortcut and paste into another window.

    Java linlks often don't wprk eiuther. I uninstalled and re-installed Java. Maybe there's some slightimprovement but browsing is still a pain.

    So now it comes down to a performance problem, mainly in IE.

    Shall I uninstall and reinstall IE?

    Why has this happened. Could Malware/spyware viruses be reponsible?

    Any help gratefully received and because it's only fair, I'll make sure every forum gets a full report when it's all fixed (It will be won't it?)

    System Description

    INTEL P4 3.4GHz, socket 775
    ASUS P5GD1-VM motherboard, onboard LAN (Intel Pro 100), onboard graphics and audio disabled
    American Megatrends BIOS version 1010.005
    2 x 512MB PC3200 400MHz DDR
    200GB Maxtor serial ATA drive - C
    500GB Seagate serial ATA drive - D
    Samsung/Toshiba DVD writer - E
    Sony Q28A DVD writer - F
    Sony DRX-810UL external DVD writer on USB - G
    ATI All in Wonder X800XL graphics card
    Creative Soundblaster XFi Xtreme Music sound card
    Logitech Dinovo Media keyboard, seperate keyboard and numeric panel/remote with mouse on powered USB hub
    Logitech Communicate STX webcam

    I run Windows XP Home Service Pack, fully updated. I defragment with Perfect Disk at least once per week.

    I use the following security software:

    Norton Internet Security 2006
    Ad-Aware SE
    Spyware Doctor
    Spy Bot
    Microsoft Antispyware
    Spyware Blaster
    Spy Sweeper

    All are updated regularly and full scans performed at least every other day.

    I also use Registry Mechanic at least once per day. And this episode has added about a dozen other utilities to my amoury.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.