TechSpot

Dial-Up Connection Settings Won't Stay Set

By CDS1120
Nov 15, 2005
  1. Here's some background on my situation. I'm running Windows XP Home under
    SP2 with a dialup internet connection. Under Tools->Internet Options->
    Connections, I need the setting to be either "Dial Whenever a Network
    Connection is Not Present" or "Always Dial My Default Connection". However,
    if I set the Connection tab to one of these options and restart my computer,
    the option always resets itself to "Never Dial a Connection".

    I have read here that there's a registry tweak to correct this. I remember seeing what keys are used in this adjustment, but I don't recall ever seeing what values need to be adjusted or to what it is necessary to adjust them. Any help? Thanks!
     
  2. Triton

    Triton TS Enthusiast Posts: 112

    http://www.experts-exchange.com/Operating_Systems/Win98/Q_21399855.html

    "Note: This restriction can be used either on a user by user basis by adding it to HKEY_CURRENT_USER or on a computer wide basis by adding it to HKEY_LOCAL_MACHINE."

    Never dial a connection set:
    "NoNetAutodial"=dword:00000000
    "EnableAutodial"=dword:00000000

    Always dial my default connection:
    "NoNetAutodial"=dword:00000000
    "EnableAutodial"=dword:00000001

    Dial whenever a network connection is not present set:
    "NoNetAutodial"=dword:00000001
    "EnableAutodial"=dword:00000000

    http://www.alegsa.com.ar/Visitas/i65/Dialup - keeps going to never dial.php
    "A third party program is resetting your dial up connection."
    "This is known to happen if you are using Norton Anti-Virus with the Auto-Protect turned on."

    http://www.cybertechhelp.com/forums/archive/index.php/t-3152.html
     
  3. CDS1120

    CDS1120 TS Rookie Topic Starter

    Thanks. Here are my current registry settings under NoNetAutoDial and EnableAutoDial:

    My Computer\HKEY USERS\S-1-5-21-134397184-2773398560-1897372217-1003\Software\Microsoft\Windows\CurrentVersion\Internet Settings
    NoNetAutoDial REG_DWORD 00000001 (1)

    My Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\InternetSettings
    NoNetAutoDial REG_DWORD 00000001 (1)

    My Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\InternetSettings
    EnableAutoDial REG_DWORD 00000001 (1)

    My Computer\HKEY USERS\S-1-5-21-134397184-2773398560-1897372217-1003\Software\Microsoft\Windows\CurrentVersion\Internet Settings
    EnableAutoDial REG_DWORD 00000001 (1)

    Do I need to edit the values containing both instances of NoNetAutoDial and EnableAutoDial? Also, for what this is worth, I have noticed that under Tools->Internet Options->Connections, the Set Default button is grayed out. Any advice on how I fix this? Thanks!
     
  4. Triton

    Triton TS Enthusiast Posts: 112

    I have never run into this problem personally. All I know about it is from reading about it.

    You should notice that your settings don't match any known configuration for the 3 options.

    "My Computer\HKEY USERS\S-1-5-21-134397184-2773398560-1897372217-1003\Software\Microsoft\Windows\CurrentVersion\Internet Settings
    NoNetAutoDial REG_DWORD 00000001 (1)"

    "My Computer\HKEY USERS\S-1-5-21-134397184-2773398560-1897372217-1003\Software\Microsoft\Windows\CurrentVersion\Internet Settings
    EnableAutoDial REG_DWORD 00000001 (1)"

    These should not both be set to 1. This may be why "Set Default button is grayed out"

    You could try setting the Global setting first "HKEY_LOCAL_MACHINE " and then the user settings and see if you get control of it in Windows.

    If the settings change back;
    Other than a program " Norton Anti Virus" changing these settings I did see one post where the problem stooped after the user ran several Anti Virus (other than Norton) and Malware scanners.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.