Direct3D Failure for ATI RADEON 9550

By Redd R
Dec 22, 2007
Topic Status:
Not open for further replies.
  1. Here's how it all started.

    I was playing games on my computer one day when someone messages me. i decide to Alt-Tab out,and the screen resolution turned to the lowest setting it could go. i didn't think of it as anything, since some of my games do that all the time. The next day all my games started doing this, and in order to fix it, i had to restart my computer to restore my resolution settings. So i decided to install the latest video drivers. The games no longer work in fullscreen. i have rolled back the drivers countless times and have tried everything. I uninstalled all things ATI related, re-installed them back, installed new drivers and it still doesn't work. I run DxDiag Direct3d testing and i get these errors.

    D3D7 Test Result: Failure at step 39 (SetDisplayMode to 640x480x16): HRESULT = 0x80004001 (Not implemented)
    D3D8 Test Result: Failure at step 8 (Creating 3D Device): HRESULT = 0x88760827 (error code)
    D3D9 Test Result: Failure at step 8 (Creating 3D Device): HRESULT = 0x8876086c (error code)


    I can't seem to find some sort of solution to this..

    Machine:

    Machine name: CPQ-S6500NX
    Operating System: Windows XP Home Edition (5.1, Build 2600) Service Pack 2 (2600.xpsp_sp2_gdr.070227-2254)
    Language: English (Regional Setting: English)
    System Manufacturer: Compaq Presario 061
    System Model: DQ181A-ABA S6500NX NA411
    BIOS: Phoenix - Award BIOS v6.00PG
    Processor: AMD Athlon(tm) XP 3000+, MMX, 3DNow, ~2.2GHz
    Memory: 1024MB RAM
    Page File: 753MB used, 1709MB available
    Windows Dir: C:\WINDOWS
    DirectX Version: DirectX 9.0c (4.09.0000.0904)
    DX Setup Parameters: None
    DxDiag Version: 5.03.2600.2180 32bit Unicode
  2. mailpup

    mailpup TS Special Forces Posts: 8,280   +181

    Try System Restore to a point before you Alt-Tabbed out.
  3. Redd R

    Redd R Newcomer, in training Topic Starter

    Bump

    Also, i have downloaded the 7.7 Catalyst. Doesn't work, unless im missing a step.


    System restore does not work, I keep incomplete getting failures...thats probably out of the question...

    is it possible that my graphics card died or fried out or something?
  4. Rik

    Rik Banned Posts: 4,985

  5. Redd R

    Redd R Newcomer, in training Topic Starter

    Okay..I will try that out once I get back from vacation. other suggestions are welcome too, because I am getting tired of restarting my computer 30 times a day.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.