DirectX 9.0c compatible trouble, please help

By Me0729
Sep 25, 2004
Topic Status:
Not open for further replies.
  1. lyndsae

    lyndsae Newcomer, in training Posts: 21

    try this and see

    noo i had the same card and my sims 2 woudln`t work either **** i found a sulution

    okay.. i can solve your problem
    do these instructions you dont have to buy a new thing or download anything

    ok so first

    1.right click on ur desktop and click properties.
    2.click settings
    3.change your colour quality to medium (16 bit) or anything that says 16 in it lol
    4. click ok lol
    5.right click on the sims2 icon on the desktop
    6.click properties and then shortcut on the top
    7. in the target line it should say somting like "C:\Program Files\EA GAMES\The Sims 2\TSBin\Sims2.exe"
    8. add a space to the end and a -w then it should work so now it should look like....

    "C:\Program Files\EA GAMES\The Sims 2\TSBin\Sims2.exe" -w

    DONT FORGET THE SPACE
  2. lyndsae

    lyndsae Newcomer, in training Posts: 21

    i can help u

  3. lyndsae

    lyndsae Newcomer, in training Posts: 21

    you dont have to buy a card


    okay.. i can solve your problem
    do these instructions you dont have to buy a new thing or download anything

    ok so first

    1.right click on ur desktop and click properties.
    2.click settings
    3.change your colour quality to medium (16 bit) or anything that says 16 in it lol
    4. click ok lol
    5.right click on the sims2 icon on the desktop
    6.click properties and then shortcut on the top
    7. in the target line it should say somting like "C:\Program Files\EA GAMES\The Sims 2\TSBin\Sims2.exe"
    8. add a space to the end and a -w then it should work so now it should look like....

    "C:\Program Files\EA GAMES\The Sims 2\TSBin\Sims2.exe" -w

    DONT FORGET THE SPACE
  4. lyndsae

    lyndsae Newcomer, in training Posts: 21

    yeah those are not capable but i know how to make the sims runn


    okay.. i can solve your problem
    do these instructions you dont have to buy a new thing or download anything

    ok so first

    1.right click on ur desktop and click properties.
    2.click settings
    3.change your colour quality to medium (16 bit) or anything that says 16 in it lol
    4. click ok lol
    5.right click on the sims2 icon on the desktop
    6.click properties and then shortcut on the top
    7. in the target line it should say somting like "C:\Program Files\EA GAMES\The Sims 2\TSBin\Sims2.exe"
    8. add a space to the end and a -w then it should work so now it should look like....

    "C:\Program Files\EA GAMES\The Sims 2\TSBin\Sims2.exe" -w

    DONT FORGET THE SPACE
  5. lyndsae

    lyndsae Newcomer, in training Posts: 21


    okay.. i can solve your problem
    do these instructions you dont have to buy a new thing or download anything

    ok so first

    1.right click on ur desktop and click properties.
    2.click settings
    3.change your colour quality to medium (16 bit) or anything that says 16 in it lol
    4. click ok lol
    5.right click on the sims2 icon on the desktop
    6.click properties and then shortcut on the top
    7. in the target line it should say somting like "C:\Program Files\EA GAMES\The Sims 2\TSBin\Sims2.exe"
    8. add a space to the end and a -w then it should work so now it should look like....

    "C:\Program Files\EA GAMES\The Sims 2\TSBin\Sims2.exe" -w

    DONT FORGET THE SPACE
  6. lyndsae

    lyndsae Newcomer, in training Posts: 21


    okay.. i can solve your problem
    do these instructions you dont have to buy a new thing or download anything

    ok so first

    1.right click on ur desktop and click properties.
    2.click settings
    3.change your colour quality to medium (16 bit) or anything that says 16 in it lol
    4. click ok lol
    5.right click on the sims2 icon on the desktop
    6.click properties and then shortcut on the top
    7. in the target line it should say somting like "C:\Program Files\EA GAMES\The Sims 2\TSBin\Sims2.exe"
    8. add a space to the end and a -w then it should work so now it should look like....

    "C:\Program Files\EA GAMES\The Sims 2\TSBin\Sims2.exe" -w

    DONT FORGET THE SPACE
  7. lyndsae

    lyndsae Newcomer, in training Posts: 21

    dotn buy a cardd


    okay.. i can solve your problem
    do these instructions you dont have to buy a new thing or download anything

    ok so first

    1.right click on ur desktop and click properties.
    2.click settings
    3.change your colour quality to medium (16 bit) or anything that says 16 in it lol
    4. click ok lol
    5.right click on the sims2 icon on the desktop
    6.click properties and then shortcut on the top
    7. in the target line it should say somting like "C:\Program Files\EA GAMES\The Sims 2\TSBin\Sims2.exe"
    8. add a space to the end and a -w then it should work so now it should look like....

    "C:\Program Files\EA GAMES\The Sims 2\TSBin\Sims2.exe" -w

    DONT FORGET THE SPACE
  8. lyndsae

    lyndsae Newcomer, in training Posts: 21

    if you havn`t found a sollution allready


    okay.. i can solve your problem
    do these instructions you dont have to buy a new thing or download anything

    ok so first

    1.right click on ur desktop and click properties.
    2.click settings
    3.change your colour quality to medium (16 bit) or anything that says 16 in it lol
    4. click ok lol
    5.right click on the sims2 icon on the desktop
    6.click properties and then shortcut on the top
    7. in the target line it should say somting like "C:\Program Files\EA GAMES\The Sims 2\TSBin\Sims2.exe"
    8. add a space to the end and a -w then it should work so now it should look like....

    "C:\Program Files\EA GAMES\The Sims 2\TSBin\Sims2.exe" -w

    DONT FORGET THE SPACE
  9. lyndsae

    lyndsae Newcomer, in training Posts: 21


    hi okay.. i can solve your problem
    do these instructions you dont have to buy a new thing or download anything

    ok so first

    1.right click on ur desktop and click properties.
    2.click settings
    3.change your colour quality to medium (16 bit) or anything that says 16 in it lol
    4. click ok lol
    5.right click on the sims2 icon on the desktop
    6.click properties and then shortcut on the top
    7. in the target line it should say somting like "C:\Program Files\EA GAMES\The Sims 2\TSBin\Sims2.exe"
    8. add a space to the end and a -w then it should work so now it should look like....

    "C:\Program Files\EA GAMES\The Sims 2\TSBin\Sims2.exe" -w

    DONT FORGET THE SPACE
  10. lyndsae

    lyndsae Newcomer, in training Posts: 21

    okay.. i can solve your problem
    do these instructions you dont have to buy a new thing or download anything

    ok so first

    1.right click on ur desktop and click properties.
    2.click settings
    3.change your colour quality to medium (16 bit) or anything that says 16 in it lol
    4. click ok lol
    5.right click on the sims2 icon on the desktop
    6.click properties and then shortcut on the top
    7. in the target line it should say somting like "C:\Program Files\EA GAMES\The Sims 2\TSBin\Sims2.exe"
    8. add a space to the end and a -w then it should work so now it should look like....

    "C:\Program Files\EA GAMES\The Sims 2\TSBin\Sims2.exe" -w

    DONT FORGET THE SPACE
  11. death_bat27_

    death_bat27_ Newcomer, in training

    I've already tried the stupid intel instructions, but NOTHING works! I need to know where I can find this DirectX 9.0c Compatible Graphics Adapter. I've had this problem before, but recently i reformated my computer and need to download the driver all over again. Where can i get this driver? thats all i need to know!
  12. lyndsae

    lyndsae Newcomer, in training Posts: 21

    well just put the space then -w have u tried that read through my instructions again
  13. lyndsae

    lyndsae Newcomer, in training Posts: 21

    how did u become like a non new comer do u have to liek work at the siteƉ
     
  14. death_bat27_

    death_bat27_ Newcomer, in training

    I've tried those instrucions multiple times, and with no results... I now have the DirectX 9.0c Compatible graphic adapter (i'll abbreviate that dx 9.0c cga) downloaded... but it still won't work. I don't know what to do, but I've had this problem before and the dx 9.0c cga worked! what AM i doing wrong??:dead:
  15. lyndsae

    lyndsae Newcomer, in training Posts: 21


    well u need a good graphics card in order to make the directX compatible work with the sims. try the -w and dont forget the space do exactly what i say here


    okay.. i can solve your problem
    do these instructions you dont have to buy a new thing or download anything

    ok so first

    1.right click on ur desktop and click properties.
    2.click settings
    3.change your colour quality to medium (16 bit) or anything that says 16 in it lol
    4. click ok lol
    5.right click on the sims2 icon on the desktop
    6.click properties and then shortcut on the top
    7. in the target line it should say somting like "C:\Program Files\EA GAMES\The Sims 2\TSBin\Sims2.exe"
    8. add a space to the end and a -w then it should work so now it should look like....

    "C:\Program Files\EA GAMES\The Sims 2\TSBin\Sims2.exe" -w

    DONT FORGET THE SPACE
  16. death_bat27_

    death_bat27_ Newcomer, in training

    I've done that, and I know my graphics chip is fine, anything else
  17. Sharkfood

    Sharkfood TechSpot Guru Posts: 1,198

    Okay, this is REALLY getting confusing since a whole bunch of people with different systems are replying on this thread and many of which have provided NO system information from which to yield meaningful advice.

    I would HIGHLY recommend those here with problems with the Sims 2 to create a *NEW* thread, topic: "Problem playing Sims2" or similar, and be sure to either:
    a) Fill out your profile information (User Profile link above) with your system information, if you know it: we need motherboard, cpu, memory, videocard, operating system and any other information you may need.
    or
    b) Run DxDiag and export this to a file and attach or copy/paste this to the end of your post.

    To run a dxdiag, perform the following:
    1) Start Menu, Run... and type: dxdiag in the "Open:" slot, then press OK.
    2) If you are asked for connecting to the internet to check WHQL, hit YES if your PC is currently connected to the internet, else click NO.
    3) Once in DxDiag, wait patiently for the green progress bar on the left to complete.
    4) Click on the "Save All Information" button on the bottom and choose somewhere you will remember for this. I'd recommend the desktop and go ahead and call it DXDIAG or similar.
    --
    You can either ZIP this file as-is and attach to your post (see the Manage Attachments button when creating a thread...
    --or---
    You can pull this file into Notepad or other editor and copy up until the DirectShow Filters portion. We dont need anything past this portion.


    From there, we can work with each individual user encountering problems and not have so much cross-posting or confusion for who is talking to whom or what solutions for each individual to try.
  18. lyndsae

    lyndsae Newcomer, in training Posts: 21

    well you graphics chip isn`t fine because it wont handle the directX if ur chip is upgraded enogh then it will be able to use direct X with the sims other then that -w is all i can say
  19. death_bat27_

    death_bat27_ Newcomer, in training

    *tear* ok... thanks for your help...
  20. kjade37

    kjade37 Newcomer, in training

    I have the same system and video card, if you could give me help with the Gateway I would appreciate it.
    Thank you.
  21. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 7,277   +22

    Both of u will need to buy a standalone graphics card to run the game. There is nothing else u can do.
  22. benj.sinister

    benj.sinister Newcomer, in training

    Hhhhhhhheeeeeeeeeeeelllllppppppp!!!

    The story went like this:

    Before, I was able to play the Sims 2.. I upgraded my Windows XP version to Windows XP SP2. After that, I opened the Sims 2 it says that I have no compatible DirectX9.0c graphics adapter. I downloaded EVEREST HOME Edition.. It says I have a Display adapter - VIA/S3 Unichrome Pro and also a 3D accelerator.

    The problem I think is my system cannot detect my DISPLAY DRIVER.. In dxdiag, it says I'm using the generic video driver. It says my main driver is: vga.dll.. Anyone who can help me? I think it cannot detect video driver and disabled the graphics controller. How can I enable the graphics controller?

    anyone, please mail me I would greatly appreciate it! justinmejos@gmail.com
  23. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 7,277   +22

    Try here. Look for ur chipset name and number in Everest and look for it on the page I linked to. That will help u get the appropriate drivers for ur motherboard.
  24. benj.sinister

    benj.sinister Newcomer, in training

    But how am I going to enable my graphics controller status and AGP status? My system cannot detect my display adapter even though I have one because I reinstalled Windows XP. I already downloaded those drivers but no luck.. In Everest I clicked Motherboard and then chipset, it says:

    Graphics Controller Type: Via/S3 Unichrome Pro IGP
    Graphics COntroller Status: DISABLED..

    How can I enable it?
  25. becca

    becca Newcomer, in training

    help!!!

    i know practically noting about computers except the basics. all that i know is that when i try to play sims 2 it says that "failed to find any DirectX 9.0c compatible graphics adapters in this system! please make sure you have a DirectX 9.0c compatible adapter and have installed the latest drivers provided by the manufaturer. the application will now terminate." as i have read a lot of you are very familiar with this. sims 2 used to work, but a while ago it just stoped working and started saying that mouth full. i used the troubleshooting thing and found out that i actually do have the DirectX9.0c adapter so im not sure why it says that. i also noticed that my screen isn't its usual 800x600 it is now 640x480 and im not sure why. let me know, PLEASE!!!!!
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.