disk write caching disabled

By olefarte
Aug 3, 2004
  1. I have a Maxtor Diamond Max Plus 9 200 gig Hard Drive, 8mb cache buffer, running on XP. with P4, 3.06. When I run Boot Vis, it says "warning disk write cache disabled". If this is enabled, won't my computer boot faster and run and load faster, in general?

    It seems to me I have seen somewhere that it has to do with hyperthreading, it has to be disabled? If this is true, is there any advantage in disabling hyperthreading in order get the 8 mb cache enabled. Is hyperthreading reall necessary? I run mostly games on this computer.

    SHOULD it be enabled, and if so how do I do all this, in the bios?
  2. guruboy

    guruboy TS Rookie Posts: 26


    According to this article:

    Write caching may cause slower disk performance in 2k and XP. I haven't really experimented with write caching on my Maxtor drive (a 200gB) or my Western Digital (WD-800JB). In fact, I'm not even sure if they have write-caching enabled.

    You might want to check out this link, which tells you how to disable write-caching (it's Device Manager-based):

    Of course, as I'm sure you know, be careful when doing things with your hard drives. :)
  3. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,343   +6

    After looking in Device manager per in structions in that article, contrary to Boot Vis, it says it is already enabled. I think I'll just leave things the way they are, and be safe.

    Thanks for the reply.
  4. guruboy

    guruboy TS Rookie Posts: 26

    Now that I check it, I have both enabled on my drives at home. I've never really had a performance problem with either of my drives, but that's because I made sure when I set my machine up that I was using the proper ATA-spec cables.

    I'd eventually like to upgrade to SATA disks, but that's for my next machine.
  5. Yavor76

    Yavor76 TS Rookie

    ...and if you buy SATA you can not have "write caching"..I have SATA Maxtor 6Y120MO but write caching is disabled! . In device manager is enabled,but don't working-bootvis says that is disabled. I wrote a question to "Maxtor" support about this and i will wait for answer! If you know how to enable it please help(may be some option in BIOS...i dont know)
  6. Cheap PC Man

    Cheap PC Man TS Rookie


    Im using a Maxtor 200Gb SATA HDD in my new XP build and Im having BOOTVIS mention the same thing even though windows says write cache enabled.

    The thing that brought it to my attention was I was investigating why this new build takes around 2 minutes to boot up into WIndows, when my other older machines take less than a minute.

    So interested in seeing what Maxtor have to say ! Let me know?

    In the meantime, anyone have an idea on if this is actually a problem ?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...