TechSpot

Downloader.BEW - mostly solved - need logs reviewed

By scifibum
Oct 13, 2007
  1. Hi,

    I was infected with downloader.bew and I used findawf to restore the files and delete the bak folders as others have been instructed. My system seems back to normal and I'm not finding any problems with Ad-aware, SpyBot S&D, Norton antivirus, or the online scans at bitdefender.com and kapersky.com

    I read the instructions at "Viruses/Spyware/Malware, preliminary removal instructions" and followed all the steps.

    The Panda rootkit scan did not find anything.

    The AVG anti-spyware scan did not find anything (I did set it to quarantine anything it found).

    I have attached my hijackthis and combofix logs. If anyone sees a remaining problem I'd appreciate the help.
     
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Right click on this link DelO15Domains.inf and choose Save As. Save it to your desktop. Right click on that file and choose Install. It will run immediately (you won't be able to see anything happen). You may delete it afterwards. NOTE: This script will delete any sites you may have added to the Trusted Sites. So if you want them back, you have to add them back to the Trusted Sites again.

    Post a fresh HJT log and let me know if you`re having any problems.

    Also, please attach an awf.txt files as per the instructions below.

    Please download FindAWF to your Desktop.
    Double-click FindAWF.exe to start the tool.
    Select "option #1 - Scan for bak folders" by typing 1 and press Enter
    When the tool has completed, a report will open up in notepad. Please post the results of the awf.txt as an attachment.

    Regards Howard :wave: :wave:

    This thread is for the use of scifibum only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  3. scifibum

    scifibum TS Rookie Topic Starter

    OK, I ran the deldomains.inf

    Fresh AWF and HJT logs attached.

    Thanks very much.
     
  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Your awf.txt is clean, so no worries there.

    Your HJT log is also clean.

    1. Please download The Avenger by Swandog46 from HERE. Save it to your Desktop and extract it.

    2. Download the attached avengerscript.txt and save it to your desktop

    Note: the above code was created specifically for this user. If you are not this user, do NOT follow these directions as they could damage the workings of your system.

    3. Now, start The Avenger program by double clicking on its icon on your desktop.

    Under "Script file to execute" choose "Load script from file".
    Now click on the folder icon which will open a new window titled "open Script File"
    navigate to the file you have just downloaded, click on it and press open
    Now click on the Green Light to begin execution of the script
    Answer "Yes" twice when prompted.

    4. The Avenger will automatically do the following:

    It will Restart your computer. ( In cases where the code to execute contains "Drivers to Unload", The Avenger will actually restart your system twice.)
    On reboot, it will briefly open a black command window on your desktop, this is normal.
    After the restart, it creates a log file that should open with the results of Avenger’s actions. This log file will be located at C:\avenger.txt
    The Avenger will also have backed up all the files, etc., that you asked it to delete, and will have zipped them and moved the zip archives to C:\avenger\backup.zip.

    5. Please attach the content of c:\avenger.txt into your reply.

    Regards Howard :)

    This thread is for the use of scifibum only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     

    Attached Files:

  5. scifibum

    scifibum TS Rookie Topic Starter

    I don't see the avengerscript.txt file attached.
     
  6. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Doh! Sorry, I forgot to attach it, fixed now.

    Regards Howard :)
     
  7. scifibum

    scifibum TS Rookie Topic Starter

    OK, I ran avenger with the supplied script and it appears it worked successfully.

    Thanks.
     
  8. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    That`s fine mate.

    Unless you`re having any problems, you should be good to go.

    If you`re not having any problems, please do the following.

    Turn off system restore.(XP/ME only) See how HERE.

    Now, turn system restore back on. This will have deleted all your old restore points and any nasties that are in them. It will also have created a new, clean restore point.


    If you have any further virus/spyware problems, please post in this thread.

    Regards Howard :)

    This thread is for the use of scifibum only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  9. scifibum

    scifibum TS Rookie Topic Starter

    Your help is greatly appreciated. Cheers :)

    This thread is now closed: If you need this thread unlocking, please pm a moderator with a link to the thread.

    Only the original thread starter can do this. Anyone else, will be ignored.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...