TechSpot

Dreadfully Slow Internet Speed When Using Router

By Necrosjef
Aug 9, 2006
Topic Status:
Not open for further replies.
  1. Today i bought a router, i plugged it in and set everything up as according to the instructions i put my pc on etc and started browsing the internet. When i connected a second pc to the router both pcs internet began to run dreadfully slowly like so slow that it couldn't open webpages.

    Now when i turned off the second PC and disconnected it from the internet totally the internet was still running slow on the original PC when it was working fine before. I then tried rebooting everything and starting again but the slow internet speed remains. While writing this message iam using a direct internet connection from the modem to the PC btw :p

    I made sure on both PCs all programs were closed except internet explorer and explorer.exe aswell but this made no difference.

    I'am using a 2.2Mb ADSL connection and iam assured by my ISP that 2.2Mb is more than enough for two pcs to use between them.

    Can anyone with experience of this problem help me out i don't really know what is going on here.

    Thanks in advance
  2. mikescorpio81

    mikescorpio81 TS Rookie Posts: 574

    You might want to try a few ping tests:

    1. Try and ping your router (note the speed in ms, should be 1)
    2. Try and png your 2nd PC (should also be quite quick)
    3. Try and ping a public ip address in your country (or a website, should be under 100)
    4. Try and ping www.ireland.com

    If you receive timeout errors or extremely high times (1000+ ms) then something is taking up your bandwidth perhaps. Let me know how u go & if need be i'll guide u further :grinthumb
  3. Necrosjef

    Necrosjef TS Member Topic Starter Posts: 69

    Ok i turned off my wireless stuff on my router and im using cables only now.

    The problem is less severe now. I can now open websites but slowly and i can now have very limited performance like download speed of 3kb/s when downloading with lots of interrupts.

    I changed mostly all settings on the router and tried lots of combinations but it didnt work at all. Someone suggested using a program called internet turbo 2003 but it makes no difference.

    Any idea on how to fix this slowness so that the 2.2MB connection goes to a 1.1MB on both comps and not like a 28.8k modem.

    Thx
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.