Driver problems with DWL-510

By coastymad
Dec 3, 2005
  1. I have recently bought a DLink DWL-510, i know it's ancient but hey, I don't have the money, anyway when I download a driver (from anywhere), when i run the setup wizard I get this Message, "1608: Unable to create InstallDriver instance. Any Ideas?
  2. coastymad

    coastymad TS Rookie Topic Starter Posts: 103

    Don't worry, I've sorted it, thanks for looking anyway.
  3. tdeg

    tdeg TS Rookie Posts: 119

    Can you tell us what you did to resolve it?

    It may help someone in the future.
  4. coastymad

    coastymad TS Rookie Topic Starter Posts: 103

    Yes, I unzipped the file with the driver then, opened the Windows Device Manager, (Start, Contor Panel, Performance and Maintenance, See basic Information about your computer, Device manager), I scrolled down to locate the Card, which for me was called SIS PCI adapter (something like that), I doubt it is the same for everyone though, but it's not hard to find as it has a yellow question mark next to it, right click on it and click Update driver, select manual, then locate the file with the driver in it, click ok, then hopefully it should say Installed successfully. I think that's what I did anyway. Oh and here's the link to the driver File:
    It's on and it requires registration, but it's completely free. If you have any questions, just send me a private message. Thanks. Coastymad.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...