DSL 2XP Pro PC's Crossover Network Problem

By dimchopicha
May 21, 2006
  1. I want to make a network between two xp pro pc's and to share internet and files.
    I have cable modem connected to 1nic on my 1pc. and 2nic on my 1pc connected to my 2pc with crossover cable.
    ip settings for the 2nic on my 1pc(lan nic):
    subnet mask:

    ip settings for the nic on my 2pc:
    subnet mask:
    default gateway:
    dns server:

    the ip settings for 1nic on my 1pc connecting to cable modem can be automatic using DHCP server or set static:
    subnet mask:
    default gateway:
    dns server:

    I am not sure what exactly I should set in network setup wizzard but anyway I am choosing second option:
    (lol something new just appear. When I start network setup wizzard a message appear: the wizzard found a shared internet connection on the computer "Unknown Internet connection Sharing device" I wonder where did came from when I disabled the windows firewall/ICS service. and also this Internet Gateway appear in my network connections from time to time from nowhere. Any suggestions?)
    when I am making the network I am choosing: "This computer connects to the internet through residental gatewat or through another computer on my network" option on both of the computers. Is this correct?
    Allowing file and printer sharing on both. Choosing same workgroup.
    A have made accounts on both of the pc's same names same passowords one is administrator the otherone is limited (dont want to wake up one day and my father to tell me:eek:pss sorry deleted d: and e: drive by mistake :)).
    I share the internet to the second pc using software proxy server.
    OK everything working fine: I can access files, watching moves through the network and using internet for .... some time (2 hours) usually after restart but sometimes without everything stop working.
    I am accessing pc's using \\ip adress and when it open the folders and network neighbourhood expand it shows that pc's are in workgroup "UNKNOWN" not the workgroup i choose and set before for example "HOME" when i right click my computer it shows that the computer is in "HOME" workgroup.
    I have check the cable the connectors and the lan cards they seems to be ok.
    I have Panda antivirus platinum installed with firewall and in the rules i allow all connections and ports for both mac adress and ip for each lan card.
    Dns names of the computers never worked.
    Earlier I was enabled ICS but now it is disabled (the service). Is ICS bugged and messing all my setting?

    Sorry for this very long post but I wanted to explain everything so you can have better view of my problem.
    Pls help.
    Why everything (sharing files and internet) is working and then suddenly stop (cant find computers using \\ or 2 and even cant ping each other)?
    Why the computers showing in "unknown" workgroup and in the options showing "home" workgroup.
    And what is this Internet Gateway appearing in my network connections from time to time?
    PLS PLS PLS help me I am confused and lost.
  2. mikescorpio81

    mikescorpio81 TS Rookie Posts: 293

    The easiest way to share internet and files is to do the follwoing:

    Get yourself a little switch (5 Port or whatever) and run a CAT-5 cable from your cable modem into a free port on your switch. Then run a CAT-5 cable from the other PC's NIC to the switch. Provided DHCP is provided by one of your devices (your modem/router i'd say) you should be sweet!

    Then create a local admin account on both your PC's, making sure they are identical (spelling & passwords). Turn Simple file sharing off on both PC's. Share something on one and from the other, open a run command and type \\IP address\

    You should be able to see the shared object & connect to it.

    Networking at its simplest :grinthumb
  3. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    That is if your ISP is kind enough to give out several IP addresses to one account..

    Also, both of the computers and their Windows file sharing (and haven knows what other services) are exposed to the internet. And anything Windows is a giant security hole :)

    Unless you really know about networking and are able to secure your computers, the switch idea is bad, bad, bad.
  4. dimchopicha

    dimchopicha TS Rookie Topic Starter

    I have done all from the beginig ip's workgroups for 53456347 times for the past 3 months and it seems to "work" for now. Don't know for how long maybe after the restart when again one of the pc's will go to "unknown" workgroup automatically or this internet gateway will show again and f..... up everything.
    When I try to play movie from my other computer through the network bsplayer
    stop to respond and you can see in the attackment what is the ping to the pc from which I try to play the movie or mp3 (mp3 is playing but stops every other 1 sec).
    And you can see the "UNKNOWN" workgroup even in system properties>computer name it show "WORKGROUP" workgroup.
    You can see the changed ping when I stop using the network.(ping2.jpg)
    I reinstall windows on one of the pc yesterday. Will reinstall this one too. Hope this solves my problem. Unless you have other suggestion how to solve my problem.
  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Ugh.. Those ping times are really ugly. Do you have any software firewalls running? VPN software? Packet capture?

    Try disabling them.
  6. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    only the 2nd machine should have this setting
    and what is the proxy server for

    something is confusing dhcp setup the server has a time limit on ip renew when it is renewing it may be getting confused as to the connection protocals
    if a normal modem to nic with ics the 1st nic is set to dynamic
    then enable it for ICS this should make the 2nd nic a router /gateway
    set the 1st nic in 2nd machine to dynamic OS should assign a ip to it
    I have only done this once seems thats how it was setup as test
    I posted results here some time ago maybe do search can find that post
  7. dimchopicha

    dimchopicha TS Rookie Topic Starter

    I solved the problem with that crazy ping. It was my fault, wrong configuration of my bandwidth manager program and it seems somehow my lan connection was limited on 14kb/s :eek: :O.
    But the problem with the network still exist.
    what happend today:
    I had lan and internet connection on both of the pc. Then I restarted the second one (pc2 lan pc). Everything was lost exept ping between them. I cant browse the other pc (\\ip addres). Then I restarted pc1 (internet pc) and then I had a connection (ping browsing internet) then I restarted pc1 again and when I tried to browse pc1 from pc2 with \\ip address a window came up to fill again username and pass to connect to pc1 even I was checked to remember the password and everything. When I fill them everything was ok.
    It seems pc1 cant "remember" its settings even it is not showing any changes in the settings. And pc2 cant "remeber" its workgroup even it is showing always "WORKGROUP" or pc1 cant "remember" or see that pc2 is in its workgroup and showing it is in "UNKNOWN".
    Any ideas from where could be this strange problem?
    I will uninstall my antivirus program even I am allow all traffic protocols and ports access to the other pc with both mac address and ip address.
    I think I will reinstall windows soon on pc1 (windows on pc2 is 2 days old :)) to be sure that the problem is not in the windows on pc1. And to search the problem somewhere else.
    Samstoned: I dont want to use ICS thats why I am using proxy and choose second option in network setup wizzard on pc1 and pc2. Because if I choose the first option it will turn on ICS automatically and ICS will make a big mess with my ip settings. I thing that all my problems coming from ICS I was enabled ICS earlier. But will see after reinstall.
  8. dimchopicha

    dimchopicha TS Rookie Topic Starter

    I can tell for sure after 2-3 days testing but everything is working fine now.

    I am pretty sure that the hole problem was Panda Antivirus Platinum 2006.
    How could this be. How they can make such ****.
    I set rules to allow all traffic from both pc using both ip and mac address.
    And still it prevent my lan to work right.
    I cant believe it. I will send them e-mail to tell them what really really bad product they have made.
    Thank you all for you help.
  9. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    what proxy softs did you use
    I may be need of same thing as I can't get a 3 layer switch to get past the router using 2 diff lan ip's
  10. dimchopicha

    dimchopicha TS Rookie Topic Starter
    I think it is a good program working very well.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...