TechSpot

Dual-boot problem

By 2roombas
Aug 1, 2009
  1. For a few months I was dual-booting fine with Ubuntu and Win XP. I had ubuntu as the default to load first and everything was working well until I tried to upgrade to the 9.10 alpha. Something went wrong with that and now I simply want to boot Win XP on this computer. However, when I start the computer up I get the dual-boot menu which offers these two options now:

    Windows XP Home Edition
    Windows (default)

    I have to choose Win XP else it will load the "Windows (default)" option first, then proceed to throw me an error saying I need to load some file, etc. Whenever I choose the Win XP Home Edition option everything is fine.... so that's what I do every single time

    When I go the My Computer>Properties>Advanced>System Startup to set the Win XP Home Edition as the one to load first... I "only" see that OS mentioned in that box, nothing else in there. Why is that?

    How can I get this dual-boot menu off and have it load the Win XP Home Edition first??
     
  2. raybay

    raybay TS Evangelist Posts: 7,241   +9

    Windows XP as default is the typical version. Once Windows XP discovers the other boot, it will have none of it. WXP is designed to insist on being the first boot, unless you have a dual boot with Windows XP and VISTA... Then Vista has to be first.
     
  3. 2roombas

    2roombas TS Rookie Topic Starter

    Then why do I have to choose the Win XP Home Edition option in order for my computer to function? It's not really a huge problem I suppose, but it would be sort of nice to not have to do that every single time I turn this on.
     
  4. 2roombas

    2roombas TS Rookie Topic Starter

    Anyone? Here is a copy of my boot.ini...

    [boot loader]
    timeout=10
    default=c:\wubildr.mbr
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect
     
  5. raybay

    raybay TS Evangelist Posts: 7,241   +9

    You can set it up again in a Linux version, and it should work, but if Windows Detects it is part of a dual boot, Windows XP or VISTA will cause trouble. Just be sure your dual boot is clean enough to boot alone first, and create both partitions with Linux, then have your Linux version up and running alone, before attempting an install of Windows...

    The secret seems to be not being in a position to automatically switch to Windows or your Linux version, but rather to decide at start up which partition. Then shut down, before rebooting to the other software. Windows will detect the other partition if it is part of a hot boot.
     
  6. 2roombas

    2roombas TS Rookie Topic Starter

    Thank you but maybe I wasn't clear about what is happening. See, the Linux OS is not an option in my boot up list (My Computer>Properties, etc.) even though the boot.ini has wubi in it. I was dual-booting Linux and Win XP for months with no problems at all, but after trying to install an ubuntu upgrade, the only options in my boot menu now are:..

    Windows XP Home Edition
    Windows (default)

    Yes it says "Windows (default)" as one of the options

    If I do not physically choose (use the arrow key to highlight and enter) the Windows XP Home Edition option, it will I suppose load up the other option (not sure what the diff is?!) then throw me the error:

    Windows would not start because the following file is missing or corrupt:
    <Windows root>\system32\hal.dll.
    Please re-install a copy of the above file.

    If I physically choose the Windows XP Home Edition option, I have zero problems, it will load fine and behave normal. This is what I have been doing for days now in fact.

    I would like to know why I all of a sudden have that "Windows (default)" option in that boot menu and how to remove it so I can just turn on my computer to boot up the Win XP Home Edition?

    Yes, I have rt-clicked My Computer and have done the Properties>Advanced/Settings, etc., but the "only" option in the OS pull-down is the Windows XP Home Edition, That's all that is there, yet it doesn't appear to be the default to load?!

    I cannot simply restore my Linux (I have the Live Disk so I "thought" I could do that actually) because doing so requires a restart... and with the current restart set-up on hereI encounter the "Windows (default) plus error" problem from above.

    To be honest I would be happy to just be able to turn on my computer and have is straight load Win XP and not deal with that dual-boot menu on this computer. I have two other computers and they hboth have Linux on them so this computer can remain Win XP only.

    Does that make sense?
     
  7. raybay

    raybay TS Evangelist Posts: 7,241   +9

    Yes, what you describe makes sense... and actually is a fairly common occurence... But it is Windows taking over... not Ubuntu failing to do its job, in my opinion.
    The only way I see around it is to disable Windows when you install an upgrade to a Linux software...
    Windows XP, by design, intends to take control... You gave it an opening, by the upgrade, and Windows took it.
     
  8. 2roombas

    2roombas TS Rookie Topic Starter

    Thank you for your reply. So this is common? What do I do then? Do I have to just continue doing that "physically choose" Win XP thing every time from now on?

    As I said before, I don't need Linux on this computer anymore and it can remain just Windows, that's fine. (Although I'm a Linux fan!)

    I could just clean install the whole thing, yes, but the Win XP cd I have for this computer is 10 years old so I'm sure there will have to be "a lot" of updating and reloading of everything else involved. It would sure be nice to not have to do that!
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...