TechSpot

During XP installation, cant detect hdd

By pedenski
Dec 23, 2008
  1. setup did not find any hard disk drives installed in your computer.

    this error shows every time i try to install winxp on my brand new pc. all cables are inserted perfectly.. please help me..

    the specs are
    SATA seagate barracuda 500gb 7200.11
    Gigabyte GA-G31M-S2L
    2GB Ram
     
  2. tuant

    tuant TS Booster Posts: 201

  3. pedenski

    pedenski TS Rookie Topic Starter Posts: 19

    unfortunately i dont have a floppy disk..I downloaded the drivers youve provided.. it was 'iata86enu.exe' how am i able to use that without using any floppy disk?

    and also my processor is pentium R dual core processor 2.20ghz
     
  4. tuant

    tuant TS Booster Posts: 201

    I should have mentioned this before but you should check your BIOS to see whether it recognizes your hard drive. If it does, then you are missing the SATA drivers. If it doesn't then this means either your hard drive is defective or something is wrong with the cables/connections.

    It a little more complicated to edit your Windows XP installation disc to include the sata drivers you need. http://www.tacktech.com/display.cfm?ttid=414

    To simply things, I suggest you obtain either a USB or internal floppy drive and a floppy disk.

    Good luck...
     
  5. pedenski

    pedenski TS Rookie Topic Starter Posts: 19

    im not really a computer literate person.. Im quite confused.. heres my screenie.. i dont know if it detects my SATA hdd or not.. but the physical device is attached on the MObo

    [​IMG]

    [​IMG]

    [​IMG]
     
  6. tuant

    tuant TS Booster Posts: 201

    I don't think BIOS detected your HD, Check your sata connections and power connections to the hard drive and motherboard.
     
  7. pedenski

    pedenski TS Rookie Topic Starter Posts: 19

    well, what i did.. since i dont have a floppy.. i tried saving the 'iastore -sata files' in my flash disk. and then miraculously the error ' setup did not found any hard disk drives installed in you computer' was gone.. then this agreement of XP pops up in which you need to press F8 to confirm then suddenly when I agree, i was wondering why it didnt detect my 500GB sata drive on the list. which then when I click enter this screenie shows..

    [​IMG]

    ------

    On the other hand, now that you mentioned that it didnt detect my HD, theres only 1 cable connectd to my HD to my MOBO, which is in the pic below.
    [​IMG]

    [​IMG]

    im so clueless whats still missing,
     
  8. pedenski

    pedenski TS Rookie Topic Starter Posts: 19

    This issue has been solved.. tnx TUANT for your kindness and patience in helping me out.. I reviewed all your instructions and solved the problem.. thx..
     
  9. tuant

    tuant TS Booster Posts: 201

    The installation detected a 'Drive' and it happened to be your Flash Drive. I think that's what the first picture was talking about.

    Seems like you forgot the power cable to your SATA drive.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...