DVD Rom and DVD-RW drives showing yellow !'s....Someone please help me!

By Brvsfanforlife
May 17, 2006
Topic Status:
Not open for further replies.
  1. After coming home from work one day I booted my cpu up and went to play a game, when I put the game in the drive not happened. I clicked on the game's logo on desktop I get "Please insert the correct Halo CD-ROM, select OK and restart the application", I thought it might have been just that game so i tried another and I got the same thing. I checked the device manager and all drives have the yellow !'s by them. One of them has location 0, the other location 1 but both have the same error message..."Windows successfully loaded the device driver for this hardware but cannot find the hardware device. (Code 41)"

    I went to HP's site and after 4-5 different things they had me try nothing worked. I cannot use either drive, I cant use regedit, it just pops up and then disappears immediately after. Ctrl+Alt+Del doesnt work either, so after doing full system scans with both Norton Pro, and a trial of SpySubtract most everything is clean but everything I had problems with still dont work. Ive also tried to unistall the drives and reinstall them, doesnt work. Ive tried uninstalling them, pulling the cords off the drives rebooting, then shut down, put the cables back on and cpu and see if they come back and they did but the yellow !'s did too. My only choice appears to be is to do a Non-Destructive recovery or a Full recovery, I dont want to do either till I can backup my most important stuff (my family history files, my personal files, and I used Daemon to play 2 of my games that I no longer have the discs to be able to reinstall them) but with no way to put a cd-rw or dvd-rw disc in the tray and it work I dont know what else to do.

    If anyone on here can help me prevent from losing my important data, it would be GREATLY APPRECIATED!!!!!
  2. iss

    iss TechSpot Chancellor Posts: 2,896

    did you try uninstalling the IDe channel that the drives are on, instead of uninstalling the drives themselves? if you havnt then do so in device manager under "IDE ATA/ATAPI controlers" and reboot.

    you could also try removing the drives one at a time in case one of the drives has gone bad and is causing the problem. worst case scenario your mobo is going bad.
  3. Brvsfanforlife

    Brvsfanforlife Newcomer, in training Topic Starter

    The primary and secondary IDE channels? Uninstall them?
  4. iss

    iss TechSpot Chancellor Posts: 2,896

    uninstall the ones that your optical drives are on. are they on seperate cables or both on one cable?
  5. Brvsfanforlife

    Brvsfanforlife Newcomer, in training Topic Starter

    I uninstalled both and rebooted and still the yellow !'s remain.
  6. iss

    iss TechSpot Chancellor Posts: 2,896

    Then it is likely that it is a hardware problem. if they are both on the same cable you could try replacing the cable, I have seen some IDE cables go bad. how old is the system and what are your system spec's? ie; mobo, optical drives ,etc?
  7. Brvsfanforlife

    Brvsfanforlife Newcomer, in training Topic Starter

    Im not cpu illiterate but what is a "Mobo"?
  8. iss

    iss TechSpot Chancellor Posts: 2,896

    Sorry, "Mobo" = Motherboard.
  9. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    You may want to check and see if the jumpers on those drives are set to Cable Select , if so change that to Master (Writer) and Slave (Rom )
    Next I solved that problem with a IDE controller update from Intel (if this is what is on your Mobo), just make sure you confirm the correct file by using the actual model on your Mobo.
    Are your Roms correctly identified in your BIOs? if not you might need a Bios update if one is availible.
    While you are at it check to see if a Firmware update is recommended for your RW
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.