TechSpot

E-machine breakdown

By hazer07
Dec 24, 2007
  1. Iv had my e-machine 2210 Intel® Celeron® 2.6 GHz 512mb (memory upgrade) with a Intel® D845GVSR "Sea Breeze" motherboard for quite a while and it functioned well except for the odd freeze but today it decided to just not turn on i pressed the switch and nothing changed the cable and nothing. After a while of leaving it on the fan would occasionally spin and the computer makes a strange juddering sound, the LED on the front flashes but no activity and it then just shuts down again. Any suggestions whats wrong? any solutions?
    all assistance would be greatly appreciated. Thanx
     
  2. Daveskater

    Daveskater Banned Posts: 1,687

    Hello, hazer07, and welcome to Techspot :wave:

    Please take a moment to read the following threads to make your experience here as enjoyable as possible :)

    Message for all newcomers

    SNGX1275's Guide to making a good post/thread

    The Techspot FAQ

    If you could take a minute to fill in some of your profile information that would be helpful to all members of the forum :)
    Knowing someone's location in the world can be extremely helpful, even if you just put a country.

    Also remember to post any problems or questions that you have in the appropriate forums

    With regards to your problem, eMachines are known for having cheap PSU's which blow and often take out the motherboard.

    It sounds as though this is your problem. I would suggest reading this thread: If you own an Emachine, read this now!
     
  3. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...