TechSpot

Edifier 2.1 speakers mh 1370 speaker out port problem

By kirs92
Apr 27, 2014
Post New Reply
  1. Hi there, I purchased an edifier mh 1370 multimedia speaker a while back it has been working fine. I took it to a mates place for a birthday party and when I brought it back to mine and connected it up, it seems that the right speaker out port does not work.. I've plugged the right speaker into the left port and vice versa and both speakers work so it's definitely not the speakers. I've checked my audio software and properties nothing has changed. I've checked the 3.5mm audio connecting cable. I mean all I did was bring it to a party let it run for about 9hours I think and came back used it and the right speaker port doesn't work :( Would it be an internal problem? if so how would I fix it? I don't know anything about electronics and I really don't wanna buy a new one trying to be handy here haha....
  2. hood6558

    hood6558 TS Booster Posts: 292   +44

    Plug some headphones or earbuds into the jack to make sure both channels are working. If it sounds okay, your most likely problem is the wires in your speaker system - usually the 3.5 plug or the nearby wire has separated inside the insulation. I would cut the original plug off and solder in a new one from Radio Shack, if you're okay with soldering, or have a repair shop do it if you're not able to.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.