Enable Big LBA problems

By Matt-man
Apr 13, 2005
  1. I have a 200gb Western digital hard drive as a slave on my pc. Master is a maxtor 40gb that has my OS on it.
    The problem is the Western Digital only shows as 127gb. I realise that you have to have the LBA option enabled for it to show correctly and it is enabled in BIOS and I have also downloded a checking file that has confirmed my system has everything enabled correctly. However the drive still shows as 127gb does it now need to be reformatted to show the correct amount?
    Please could you help me sort this out. :confused: :confused:
  2. zephead

    zephead TechSpot Paladin Posts: 1,569

    you're looking at a limitation on your drive controller. are you using the onboard controller? if so, what motherboard is it?
  3. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Standard LBA option is 28-bit. The BIOS must support 48-bit LBA to give the full size. Perhaps a BIOS-update?
    As of SP1, 48-bit LBA is available in Windows XP.

    For more info, see here:
  4. olefarte

    olefarte TechSpot Ambassador Posts: 1,343   +6

    I recently had the same problem with my 200 gig Maxtor after installing a new motherboard. I never did really resolve it. I finally used Partition Magic to make the unused space into another partition. At least I got the space back.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...