Enclosed HD won't read-Help please!!!

By matt48858
Sep 14, 2006
  1. I just bought a new Dell, took the old hard drive out of my HP machine, and put the drive into a 3.5" external enclosure.

    The drive booted up fine the first few times. It read as a E: drive and an F: drive, the E: drive being for HP recovery and the F: drive having all the operating files and personal files. I went through and erased files that I no longer needed (so I thought). Now the drive will not boot up. When I turn power on to the drive, the following happens:

    1) The computer recongizes that a mass storage device has been plugged in to a USB port.
    2) The E: drive shows up in My Computer. If I click on it, nothing happens.
    3) The F: drive no longer appears.
    4) All other programs stop running. For example, if I were to click on IE it will not open.

    When I turn power off to the external drive all programs on the desktop resume normally.

    Any help would be greatly appreciated! Thanks!
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415

    Hi matt48858 Welcome to the TS Forum

    Have you tried installing the Drive directly into the PC, say on the IDE channel the CDrom is on, it may be a flaky USB case,

  3. matt48858

    matt48858 TS Rookie Topic Starter

    Thanks for the reply.

    I don't want to open the case because it will void my warranty. A lame reason I know, but I want to cover myself if something happens.

    Any other suggestions?
  4. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    Dell strikes again
    try uninstall usb drivers re-install same

    if you can test on another machine see what happens
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...