TechSpot

Error 0x80004005 accurately checking XP license

By yukka
Apr 1, 2009
  1. I am currently working on a Windows XP PC which gives an error message when it tries to log into the default profile:

    "A problem is preventing windows from accurately checking the license for this computer. ERROR 0x80004005"

    This problem sends it back to the welcome screen and any attempt to log in again gives the same message.

    I have looked around the internet and found 4 possible fixes, all of which I have tried and have not been successful.

    1. Replacing

    %SystemRoot%\System32\secupd.dat
    %SystemRoot%\System32\oembios.dat
    %SystemRoot%\System32\oembios.bin


    2. Open your computer in safe mode,

    open a command promt

    Register the following DLL s
    it should be in the %system root% \ system32 folder
    just type the following statements one by one and see you got success information popup

    regsvr32 licwmi.dll
    regsvr32 regwizc.dll
    regsvr32 licdll.dll
    regsvr32 jscript.dll
    regsvr32 vbscript.dll
    regsvr32 msxml.dll
    regsvr32 shdocvw.dll
    regsvr32 softpub.dll
    regsvr32 wintrust.dll
    regsvr32 initpki.dll
    regsvr32 dssenh.dll
    regsvr32 rsaenh.dll
    regsvr32 gpkcsp.dll
    regsvr32 sccbase.dll
    regsvr32 slbcsp.dll
    regsvr32 cryptdlg.dll

    then try to restart,


    I carried this out but it had no effect.


    3. In the registry, go to
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
    Windows NT\CurrentVersion\WPAEvents

    Highlight it and File - Export (as a precaution) then
    in the right pane double click OOBETimer and very carefully change just
    the first byte (to say 00)

    Copy the two files windows\system32\wpa.dbl and wpa.bak to a
    different folder, and delete them

    Get on the internet

    Go to
    Start - All Programs - Accessories - System Tools - Activate Windows
    and use Activate on the internet now.


    This method fails as I cannot get networking in safe mode without it throwing the same logon error. Trying to get in curretly but no combination of options gives me any network so no reactivation.

    4. Removing the cryptography keys that can be installed on Dell system amongst others

    Start the computer. Press the F8 key during startup to start the computer in Safe mode.
    Start Registry Editor (Regedt32.exe).
    Delete the following registry keys in the Windows registry:
    HKEY_USERS\.DEFAULT\Software\Microsoft\Cryptography\Providers
    HKEY_USERS\S-1-5-20\Software\Microsoft\Cryptography\Providers
    Quit Registry Editor.
    Restart the computer.


    These keys didnt exist on my Windows installation so this could not be done.

    And people say XP is awesome compared to Vista.. :p
     
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

  3. yukka

    yukka TechSpot Paladin Topic Starter Posts: 830   +54

    Unfortunately this problem was not caused during the install of windows xp. I am currently repartioning the drive and will do a complete reinstall.

    I did try the method in the knowledge base article and this did not fix the problem.

    It is very annoying but it looks like a complete reinstall on a clean partition is the only answer at this time.
     
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    I agree ie That's what I'd do ;)

    Here's the exact steps (many users forget to remove the Partition)

    Microsoft's Windows XP Professional Repair Install step by step (* Including Delete Partition)
    http://www.windowsxpprofessional.windowsreinstall.com/sp2sp3installxpcdoldhdd/indexfullpage.htm

    Microsoft's Windows XP Home Repair Install step by step (* Including Delete Partition)
    http://www.windowsxphome.windowsreinstall.com/sp2sp3installxpcdoldhdd/indexfullpage.htm

    * Warning deleting the Partition will remove all User data and Windows system files
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...