TechSpot

Error (0x8007F0DA). Don't know what to do!

By manola
Jan 25, 2008
  1. HI,

    I am having problems with my laptop when upgrading Windows XP. I need to install some critical upgrades: (KB943485) and (KB941644). It appears the same error all the time: (0x8007F0DA). It also says that the cryptography service is not running and when I am trying to start it, it appears the error 998.

    I have read in some forums that it is due to some attack (virus, trojan,..).
    I have scanned my system with Avast, RegCure and Ad-Ware and they found nothing.

    What else can I do? Do you think it is a virus or a system problem?

    The AntiRootKit didn't find any Rootkit. The ComboFix didn't work so I have used Deckard's System Scanner. I am attaching the log files generated.

    I will appreciate all help!!

    Thank you
     
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Please refer to here:
    http://support.microsoft.com/kb/822798

    Scroll down the page to RESOLUTION

    try one suggestion at atime - restarting after each one completed

    Please reply back with which one fixed it.
     
  3. manola

    manola TS Rookie Topic Starter

    I'm unable to start the cryptographic services (which seems to be the cause of the problem) following the methods listed in the website you suggested. Can anyone please check the log files I attached in the original post? I still believe there is some kind of trojan messing up with the system

    thank you
     
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Can't see any malware present (in the long log)

    There are missing entries and possible non-needed startup applications, but I am no expert in viewing and advising of these files.

    Just a real quick idea on cryptographic service is it set to automatic ?

    If so, try:
    Go to a command prompt (Start - Run - Cmd) and type:
    net stop cryptsvc
    ren %systemroot%\system32\catroot2 oldcatroot2
    net start cryptsvc

    If that doesn't work:
    Go to a command prompt (Start - Run - Cmd) and type:
    net start cryptsvc
    regsvr32 softpub.dll
    regsvr32 wintrust.dll
    regsvr32 initpki.dll
    regsvr32 dssenh.dll
    regsvr32 rsaenh.dll
    regsvr32 gpkcsp.dll
    regsvr32 sccbase.dll
    regsvr32 slbcsp.dll
    regsvr32 cryptdlg.dll

    If that doesn't work:
    Try Repair windows !
     
  5. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    I don't know spanish, so that was hard to look through
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...