TechSpot

Every PC game crashes my computer

By colonel2121
Dec 3, 2007
  1. I have been looking through these forums for help, but I havent found a solution yet. What happens is when any game is played after about 3 or 4 minutes of playing, the screen goes black with the audio skipping for about 20 seconds. I have updated all drivers on my PC including motherboard and video card. I have also tried rolling back my ati videocard drivers to 7.1. I have attached the minidumps, the first 2 were with the ati 7.11 drivers and the last is with 7.1.

    Any help would be most helpful.

    CPU: AMD Athlon 64 X2 4800+
    Motherboard: Abit AN52
    RAM: Kingston 1gb 240-Pin DDR2 SDRAM DDR2 800 (PC2 6400)
    GPU: ATI Radeon 1650
    Disk Drives: Western Digital 200GB 7200 RPM IDE,
    Western Digital 400GB SATA300
    PSU: Antec SmartPower 2.0 SP-500 ATX12V 500W
    OS: Windows XP 32 bit
     
  2. samjohnson

    samjohnson TS Maniac Posts: 238

    What games are you trying to run? Your graphics card is a little out dated, you may just be trying to play games that it can't run.
    But you could have some kind of hard ware failure. Like your PSU is dying or overheating issues. Things like that. Your system other than your graphics are really good. So it is either that or some sort of hard ware failure.
     
  3. colonel2121

    colonel2121 TS Rookie Topic Starter

    I didnt think my radeon X1650 was that old, maybe a year or so, but I guess that is old now. I have tried to play everything, Max Payne, World in Conflict, Sim City Societies, Medieval Total War 2, GTA San Andreas. None of these games work. The minidumps I attached before were after World in Conflict and Sim City. My Power is brand new and I have tested it with a Ultra Power tester.
     
  4. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    have you updated your chipset drivers

    AGP to CPU controller might be out of date
     
  5. colonel2121

    colonel2121 TS Rookie Topic Starter

    Yeah I have updated all drivers. I dont have agp on this motherboard, its PCIexpress, and every motherboard driver I could find has been updated.
     
  6. colonel2121

    colonel2121 TS Rookie Topic Starter

    Anyone have any ideas of what could be causing this?

    I truly appreciate any help. I have been dealing with this for about month now.

    Thank you
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...