TechSpot

External Access To FTP Server

By Punkid
Dec 7, 2009
  1. ok so heres the deal, i have an FTP server setup using FIlezilla Server , it is only accessible from my home network using my computer's internal network (LAN) IP address (192.168.xxx.xxx)...i used Dyndns.com to make a domain for my WAN IP address...now when i open this domain address as HTTP , it opens up my router config page!!!! y does that happen???? and if i do it like FTP://domain.blabla.com it asks for a username and password, when i put the login for FTP user account, nothing happens....and the Server client interface does not show whether any attempt was made to connect to the server..

    PLZ HELP ME, WHAT AM I DOING WRONG? IS IT SOMETHING WRONG IN THE ROUTER CONFIG?

    P.S : I HAVE FORWARDED PORT 21 TO MY PC (i.e the pc which hosts the server)
     
  2. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    FTP needs two ports; 20 and 21; forward both to the lan address of the FTP server.

    As for external access to your router; O U C H ! :mad:
    you should never forward port 80 into your system(s) Unless you also have a webserver active. Also be sure you have changed the router admin password.
     
  3. Punkid

    Punkid TS Maniac Topic Starter Posts: 546

    i didnt forward port 80... ok i will try forwarding port 20 too
     
  4. Punkid

    Punkid TS Maniac Topic Starter Posts: 546

    i forwarded port 20 along with port 21, nothing changed...i even reset my router and still , when i open dyndns address the router's config page comes up, but i asked my friend to open the address and it didnt come up for him, now what is the problem?
     
  5. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    >> Also be sure you have changed the router admin password.!!!
    Did you?

    hmm; from you to a friend? Which one of you have the ftp server running. It doesn't come
    on our Client Systems {XP, Vista, Win/7} -- it's only available on Windows Server editions
     
  6. Punkid

    Punkid TS Maniac Topic Starter Posts: 546

    i have the server, made it using filezilla server
     
  7. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    try this from a CMD prompt
    telnet yourFTP ipaddress(or the domainname) 21​
    you should get back ...
    Connected to xxxx
    Escape character is '^]'.
    220--- something​
    What do YOU see?
     
  8. Punkid

    Punkid TS Maniac Topic Starter Posts: 546

    what do u mean with yourFTP???
     
  9. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    the IPaddress of the system with the active ftp service OR
    use the domainName if you have one(in which case BOTH must work)
     
  10. Punkid

    Punkid TS Maniac Topic Starter Posts: 546

    ok, so when i type telnet xxx.xxx.xxx.xxx it says

    'telnet' is not recognized as an internal or external command,
    operable program or batch file.
     
  11. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    my my! haven't see that issue before. Every system I've seen has
    \windows\system32\telnet.exe

    try the absolute path to it please

    [btw: I have a business appointment and will be offline for a few hours ...]
     
     
  12. Punkid

    Punkid TS Maniac Topic Starter Posts: 546

    hey theres not telnet.exe in the system folder :O
     
  13. Punkid

    Punkid TS Maniac Topic Starter Posts: 546

    hey the server aint even working from within my home network, i tried from the other pc and it is not working....only works from my pc :p (which is the WANNABE server itself)


    and as for the telnet.exe , i checked on the other pc it also does not have it, i have windows 7 so maybe its not meant to be there
     
  14. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    oh goody :( you certainly have a connectivity issue -- likely to be the firewall is block all inputs.

    I would have recommended WinAudit as a means to document what you have running,
    but not at all certain it will run on Win/7.
     
  15. Punkid

    Punkid TS Maniac Topic Starter Posts: 546

    by firewall you mean the firewall in my PC or the firewall of the router??? and heres another thing i would like to tell you, media sharing, a feature in win7 does not work from my PC...i mean, other PC's dont see my shared media , but i can see the shared media of other PC in my home.....are these problems related?
     
  16. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    the PC firewall for a certainty, and if your modem/router has the FW feature, it should have defaulted to correct settings -- unlikely you would have changed them.
    Let's solve one problem at a time :)
     
  17. Punkid

    Punkid TS Maniac Topic Starter Posts: 546

    i restored default setting for my PC firewall ( windows firewall) and as i told u earlier i had already reset my router...but still the server aint even accessible from the internal network!!!! i remember that a long time ago i made a server that was accessible atleast from my home network!
     
  18. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    yes, it is easily done -- I have Apache on my laptop and do this every day.

    for all LAN attached devices, access is via the IP address
    for the server machine, the firewall must permit
    inbout tcp any src-ip dest port xxx (whatever the server uses)

    for external access, the router just port forwards port xxx to the server ip-address.

    try this
    1. Click , type cmd in the Start Search box,
    right-click cmd.exe, click "Run as administrator", and then press Continue.
    2. Type netsh winsock reset
    3. Type netsh int ip reset
    4. Type netsh interface ip delete arpcache ​
     
  19. Punkid

    Punkid TS Maniac Topic Starter Posts: 546

    i did the things u told me, but nothing changed at all
     
  20. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    sorry - - I can't solve it from here - - it needs hands-on.

    Post#18 is your outline for the solution; get someone locally to help you
     
  21. Punkid

    Punkid TS Maniac Topic Starter Posts: 546

    ok thanks anyway
     
  22. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    you should get FTP working on your LAN before you experiment with
    port forwarding from your router.

    CAVEAT EMPTOR; FTP is insecure and the passwords are sent in clear text, ie unencrypted.

    Once FTP is running, you should opt to use SSH instead of FTP -- it has secure passwords and data exchange.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.