External FDD "Device not ready"

By silver threads
Jul 1, 2005
  1. I have just done an XP System Restore as my laptop was overloaded with junk. Everything went fine until I tried to use my USB external floppy drive only to get the message "Device not ready." I now cannot access anything on the floppy. I don't know what has caused this to happen as it worked fine before. The BIOS states fdd is disabled (the laptop does not have a floppy drive fitted.)

    There must be a simple explanation for this but I am at a loss to find it. The device mannager shows that everything is in order

    Can anyone out there help?

    Many thanks.
  2. mailpup

    mailpup TS Special Forces Posts: 6,964   +355

    Well, you could undo the system restore, get your USB function back and get rid of all the "junk" in better way.
  3. silver threads

    silver threads TS Rookie Topic Starter

    "Junk" is gone. Everything nice and tidy again but still no USB fdd function.
    Any ideas?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...