TechSpot

External Hard drive "bug?"

By abaddonsghost
Jan 5, 2010
  1. My external hard drive which ive been using for around 3-4 months has now started acting strange...either that or my computer.
    When i plug in my external the safely remove thing never shows up.
    I have tried the batch execution thing and it doesnt show up there either.
    Its a Western Digital 250gb, and im running XP SP3 if that helps.
    Its on optimize for quick removal but that doesnt stop it from writing stuff to the disk,
    Example... when i take it out( i wait till the light stops flashing) a error comes up saying "Delayed Disk write" to hard disk 3 or something.
    This hard drive has many of my important data that wont fit on my computer so... i cant really format it or anything.
    USB flash drives are working correctly its just external hard drives.
    Also my external in device manager is considered a disk drive not a removable drive..if that makes any difference

    P.S if this post is in the wrong section of forums please dont delete it just move it.

    ***Update*** 5 hours later and now my flash drives are doing the same thing....So im absolutely stumped
     
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    You might take look through here for some things to try: See Troubleshoot: Windows Won't Recognize Your USB Hard Drive

    In particular I'd start with
    > Making sure you run Custom for Windows Updates. Make sure all hardware optional as well as the critical updates are installed
    > Run the DriveCleanup Tool
    > Try reinstalling USB controllers and motherboard chipset drivers
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...