TechSpot

External HDD starting and stopping again.

By HardDriver
Nov 14, 2011
Post New Reply
  1. Hello there. Just hoping to see if I can get help with a certain problem I'm having currently with my Seagate external hard drive. When I plug it to the computer, it starts up and shows up on My Computer...for all of 5 seconds :^(

    It just seems to start and stop, sometimes it takes a while to start up and sometimes I have to pick it up and hold it for a bit before the green light comes on and it loads up (again, for only about a few seconds). Does anyone know what could be wrong with it??? Any help at this point would be appreciated, thanks!

    HD
     
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    If the external drive does the same thing on another computer, you can be sure it is a dying drive...
     
  3. techsuitor

    techsuitor TS Rookie Posts: 131

    Does this issue happens when you plug it in the USB slot? Have you tried plugging it on the other slot? What happened?
    If the result is still the same, please try to use another USB connector and plug it back. Does this gave the same result? If not, its with the USB cable's problem, but if yes, this may be to the external hard drive's.
     
  4. mike1959

    mike1959 TS Evangelist Posts: 1,026   +51

    I have a 1TB Seagate USB HD. Same sort of thing happens. It appears in 'Computer'... then gone!
    Try this. Connect the drive. When connected, go to 'disconnect USB' icon in the tray, (the white up arrow, then the green tick and silver USB icon),
    choose the 'Eject Desktop' option, and pull the USB connector out.
    Reconnect the USB plug and it should then be ok.
    This is what works for me.
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...