TechSpot

failed to initlize sound effects.Please check audio drivers

By momsgonelooney
Jul 28, 2007
  1. that is the error message i receive wen i try to play any of my games.here is a summary of my comps. specs. by everest. any help would be appreciated. ty in advance.
     
  2. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 5,431   +28

    Download the drivers for your chipset from here and install them. Reboot when asked to and then your sound should work fine.
     
  3. momsgonelooney

    momsgonelooney TS Rookie Topic Starter Posts: 124

    how do i know which chip set i have?
     
  4. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 5,431   +28

    The report states that the chipset is an nForce3 one. I have provided a link to the drivers. Click on the 'here' in my post and it'll take you to the page with the download button. Just tick the checkbox that says "I accept the terms and conditions" or something like that and click the download button. The drivers should start to download as a .exe file. After it's downloaded, just run it and it'll start installing all the drivers.
     
  5. momsgonelooney

    momsgonelooney TS Rookie Topic Starter Posts: 124

    thanks man i'll let u know wat happens..I dled them, installed them, and restarted comp. but, i still get the same error message.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...