Far Cry 3 won't launch. Windows XP

By EndaBuckley
Oct 3, 2014
Post New Reply
  1. Hi there.

    Ok, I bought Far Cry 3 from a local game store the other day and decided to try it for Windows XP. I know XP is pretty ancient by now but it's listed as being supported under the system requirements for this game so, what the hell, I said I'd give it a go.

    It installed fine and I was able to run the game pretty adequately (via Uplay) albeit some very choppy graphics and stuttering speech/dialogue glitches at times.

    So I decided to update my video card driver as I suspected that it was a few months out of date. I have an NVidia GeForce GTX 260 and so I updated to latest driver, which is now the GeForce 340.52 driver. This took a little while and required a reboot.

    So when I tried to play the game for the second time on Uplay (with the video card driver updated) it simply will not start. I click on 'Play Far Cry 3' and the black rectangular logo screen comes up and it just stays like this for awhile. This is constantly happening and I am unable to play the game now. My other games play fine, and I can even run the Far Cry 3 Map Editor, but as for the actual game, no dice.

    I'm sure there's a solution to this and I would appreciate any support! Attached are a DxDiag file and a Jpeg containing the frozen logo screen.


    Attached Files:

  2. EndaBuckley

    EndaBuckley TS Rookie Topic Starter Posts: 22

    Tried rolling back to the previous driver.. STILL nothing, It just won't launch! This is seriously annoying me now.

    I know it's something so minute because the game was playing fine when I launched it for the first time.

    I just can't put my finger on it..........
  3. EndaBuckley

    EndaBuckley TS Rookie Topic Starter Posts: 22

    Game is working now!

    Deleting the game profile under \Documents\my games\Far Cry 3\GamerProfile.xml and let it rebuild when you launch the game (you'll have to change all your video settings back afterwards).

    This did the trick, and the game finally launches into the menu screen.

    Must be that I increased the settings in the game controls from normal to high the FIRST time I played, and when I tried to launch the game the second time, the game refused to start due to these settings being saved.

    You can tick this one off as being solved!
    Cobalt006 and JohnCB like this.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...