TechSpot

File sharing not working

By oct714
Dec 23, 2007
  1. I have a 4 PC's home network:
    PC1: P4 2.4, 512MB RAM, 40GBHDD,20GB free).
    PC2: P4 3.4, 2GB RAM, 300GB HDD, 60GB free)
    PC3: AMD 3800+, 1GB RAM, 80Gb HDD, 40GB free)
    PC4: laptop centrino 1.6, 1,5GB RAM, 40GB HDD, 20GB free)


    All of them use windows XP pro Sp2, with all updates.
    All have access to the internet & can ping from each other.
    All use simple file sharing, and share the same group name
    All of them are virus & spyware free (I assume. I keep monitoring files running on startup & background).
    All have a few shared folders for others to access them, but when trying to use them, PC1 cannot not even see the other 3 PC's. The other 3 cannot see PC1 either.
    PC2 can see & access files on PC3 and PC4, but these cannot access PC2 files (PC2 is not accessible). PC3 and PC4 can see & access each other's files without any problem.

    Now, PC3 & PC4 have a recently clean windows installation. PC1 & PC2 have been used for a while, I have removed stuff, disable services, etc, trying to speed up and increase security. Thanks to this both have been working fine, fast & reliable.
    Now that I have problems sharing folders, I have disabled Zonealarm, norton, spybot search & destory with the same results.

    What do you think I might have disabled or how would I be able to fix this problem without having to reinstall windows?
     
  2. wildman6801

    wildman6801 TS Rookie Posts: 63

    Go into "My Networking Places" and click on the left hand side panel "View Network Connections" then right click on you network adapter the click on "Properties".

    In the list make sure that you have the following items in the box in the middle.
    "Client for Microsoft Networks"
    "File and Printer Sharing For Microsoft Networks"
    "Internet Protocol (TCP/IP)"

    If any are missing any then click "Install" button at the bottom of the list and install the one that is missing. This would be a good place to start.

    If they are all installed then check out you firewall you have installed on your computer and disable it and check to see if you can share if you can then the firewall needs to know that you are sharing files over the network. Look at your documentation for your firewall to configure this.

    Travis
     
  3. oct714

    oct714 TS Rookie Topic Starter

    "Client for Windows Networks", "File and Printer Sharing for Microsoft Networks", and "Internet Protocol(TCP/IP)" have always been installed & enabled on all PC's.
     
  4. wildman6801

    wildman6801 TS Rookie Posts: 63

    okay are you part of the same workgroup. Check by right clicking on "My Computer" and choose "Properties" then click the tab "Computer Name" check the "Workgroup" information. Make sure it reads the same on all four of the machines. If it does then your good on that part. If it doesn't then click the button "Change" and under the "Workgroup" field type in a workgroup that is common to all of you computers.
     
  5. jobeard

    jobeard TS Ambassador Posts: 9,348   +622

    the firewall needs the following rules on EVERY system:
    allow tcp source-add xx[*] dest-add xx[*] port 137,139,445​
    where [*] is a range of ip addresses that are on your subnet.
    use run->cmd /k ipconfig to find your specific ip-address (say 192.168.0.x)
    then the xx would be 192.168.0.2-192.168.0.255

    port 137 will allow system names to be seen under Workgroups and the file sharing runs on 139 or 445.

    *this is NOT the same thing as pinging another system :)
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...