TechSpot

Firefox and IE HTML table display troubles!

By freesuperhero
Sep 11, 2005
  1. I'm having trouble displaying an image correctly on Firefox. I've cut up an image and put it back together to be displayed in an HTML table. The thing is it displays fine in IE, but when I browse it through Firefox, it shows spaces inbetween where I've cut the image. I've been looking through my code, and I have commands to set the cellspacing and cellpadding to 0. But that doesn't seem to be the problem. I'm forgetting to do something, I just can't figure it out... Help! Here's my page:

    http://www.freesuperheroes.com/
     
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 8,165

    2 things to try.
    I always use: border="0" instead of border=0

    Instead of:
    <TABLE WIDTH="100%" HEIGHT="100%" BORDER=0 CELLPADDING=0 CELLSPACING=0>
    <TR><TD ALIGN=CENTER><IMG SRC="BIGGZ/Menus/title1.jpg" BORDER=0></TD></TR>

    <TR><TD ALIGN=CENTER><IMG SRC="BIGGZ/Menus/title2.jpg" BORDER=0></TD></TR>
    <TR><TD ALIGN=CENTER><IMG SRC="BIGGZ/Menus/title3.jpg" BORDER=0></TD></TR>
    <TR><TD ALIGN=CENTER><IMG SRC="BIGGZ/Menus/title4.jpg" BORDER=0></TD></TR>
    <TR><TD ALIGN=CENTER><IMG SRC="BIGGZ/Menus/title5.jpg" BORDER=0 USEMAP="#title1"></TD></TR>
    <TR><TD ALIGN=CENTER><IMG SRC="BIGGZ/Menus/title6.jpg" BORDER=0 USEMAP="#title2"></TD></TR>


    try
    <TABLE WIDTH="100%" HEIGHT="100%" BORDER=0 CELLPADDING=0 CELLSPACING=0>
    <TR><TD ALIGN=CENTER>
    <IMG SRC="BIGGZ/Menus/title1.jpg" BORDER="0"><BR>
    <IMG SRC="BIGGZ/Menus/title2.jpg" BORDER="0"><BR>
    <IMG SRC="BIGGZ/Menus/title3.jpg" BORDER="0"><BR>
    <IMG SRC="BIGGZ/Menus/title4.jpg" BORDER="0"><BR>
    <IMG SRC="BIGGZ/Menus/title5.jpg" BORDER="0" USEMAP="#title1"><BR>
    <IMG SRC="BIGGZ/Menus/title6.jpg" BORDER="0" USEMAP="#title2"></TD></TR>
     
  3. freesuperhero

    freesuperhero TS Rookie Topic Starter

    Well I tried both those ways you suggested (thanks for replying by the way), but they didn't seem to work. I thought for sure making the images all in one TR and split up by the <BR> commands should've worked. But to my surprise it still didn't! There must be something firefox is setting up as a default setting that I need to turn off manually... what that is... I have no idea. I'm pretty stumped.

    http://www.freesuperheroes.com/
     
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 8,165

    Your Doctype line at the very start is wrong.

    Yours has: <!DOCTYPE HTML PUBLIC "-W3C//DTD HTML 4.0 Final//EN">

    Should be: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
     
  5. fraugefahr

    fraugefahr TS Rookie

    Firefox problems

    Your Doctype line at the very start is wrong.

    Yours has: <!DOCTYPE HTML PUBLIC "-W3C//DTD HTML 4.0 Final//EN">

    Should be: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

    I am having the same problems and I tried setting the DOC type, but it didn't help. Does anyone have any other ideas?

    Thanks,
    Kristen
     
  6. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 8,165

    Dangerwoman sounds better than fraugefahr, I'd say!
    Aber Spass beiseite, what is your problem exactly?
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.