TechSpot

Firewall always turns off whenever I restart or open the PC

By abe10tiger
Jan 11, 2010
  1. Hi. Something seems to be wrong. Everytime I restart the laptop or open it, a message keeps popping out that windows firewall is off and turns on again after a while. Is it a virus or something else? Please help me. thanks.
     
  2. jobeard

    jobeard TS Ambassador Posts: 9,310   +617

    which firewall are you using?

    Firewalls are usually found as a Service (run->services.msc) and need to be set AUTOSTART
     
  3. abe10tiger

    abe10tiger TechSpot Paladin Topic Starter Posts: 770   +10

    Hi

    I'm Using WindowsFirewall
     
  4. abe10tiger

    abe10tiger TechSpot Paladin Topic Starter Posts: 770   +10

    Windows firewall was already set to turn on automatically when i start the pc...
     
  5. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    Since you have posted in the Virus and Malware forum, it would be in your best interest to go through the steps HERE.

    When you have finished, please attach the 3 logs for review. Be sure to check the lines on both Malwarebytes and Superantispyware to remove the entries found. I will instruct you on what entries need to be removed in the HijackThis log.
     
  6. abe10tiger

    abe10tiger TechSpot Paladin Topic Starter Posts: 770   +10

  7. ucould2

    ucould2 TS Guru Posts: 271

    I've had this if it's only the Windows shield that comes up RED then asks you to "click this balloon to fix "? You may have your Firewall set to manual start. Here's how to to get to it (Windows XP is my O/S hope this helps)
    Firstly you need to have Administrator rights (without this you won't access the Logs)
    /\ "My Computer" -1 left click then 1right click with mouse
    /\ drop down menu left click "Manage"
    /\ " Computer Management" opens
    /\ left click on (+) at " Services and Applications"
    /\ left click on "Services" and a large Log file opens in the right window with icons of yellow and white cogs
    /\ scroll all the way down to the log file named "Windows Firewall/Internet Connection Sharing(ICS)"
    /\ 1 left click then 1 right click with mouse
    /\ drop down menu click "Properties"
    /\ at the "General" tab "Startup type" heading should read "Automatic" if not open up selections menu on right and select it. After any change the bottom right corner button highlights "APPLY" click this button, "OK" to proceed. Next restart or open the PC Firewall should start Automatically as you've altered the setting. :monkey:
     
  8. abe10tiger

    abe10tiger TechSpot Paladin Topic Starter Posts: 770   +10

    is there an easier way to do this?

    Can you explain this to me alittle easier cause i'm not really an expert. thanks.
     
  9. ucould2

    ucould2 TS Guru Posts: 271

    Are you the Administrator?

    You need to be able to log in as the Administrator not a User (also called privileges)
    /\ This is the beginning of a new step there are nine steps
    (+) is a plus symbol that is next to the Heading "Services and Applications" ignore the brackets
    Change screens keep the instructions open (minimise your web browser or print it out)
    If your system is the same as mine the steps will be the same walk your self through it. These words I've written are "quotes" it will explain it's self as you achieve the next step
    :)
     
  10. abe10tiger

    abe10tiger TechSpot Paladin Topic Starter Posts: 770   +10

    yup..... i'm an administrator.

    Yes i am. .Firewall is already set to automatic. And all i had to do was start, then run, the typed in : services.msc then set firewall to automatic....
     
  11. ucould2

    ucould2 TS Guru Posts: 271

    Nice short-cut!

    Nice short-cut I'll try to remember it thanks
    This is the "Path To Executable" my system uses
    Also under the "Recovery tab all my drop down menus are set to "Take No Action"
    Hope you see similar and you've done all I have done. This is what fixed my similar problem, I'll stop answering and you should ask both the above
    And
    a question each here in this thread. ( you can ask them the same thing but do it in two separate posts ) :)
     
  12. abe10tiger

    abe10tiger TechSpot Paladin Topic Starter Posts: 770   +10

    ok. thanks

    Thanks. I'll tell you if i fixed the problem. Thanks : )
     
  13. ucould2

    ucould2 TS Guru Posts: 271

    What color shield Red or Yellow?

    I borrowed a DVB-T tuner only a day or two ago and loaded a program on the supplied mini~disc onto my HD. Then plugged in the ' WandTV, digital terrestrial TV stick ' to the USB on my tower. No sooner had I clicked on:
    /\ Start
    /\ Programs
    /\ Blaze HDTV Player Deluxe 4.0
    and my Windows(R) firewall indicated that it was OFF. I clicked the link then followed the instructions and manually turned it ON again!

    The first time I installed it (Blaze HDTV Player Deluxe 4.0) I got such a shock that immediately Un~installed the TV tuner device. I new that it was to blame as I had no other connections or programs running at the time (of the first new installation) and witnessed first hand what you had! :dead:
    Just thought I'd share
     
  14. abe10tiger

    abe10tiger TechSpot Paladin Topic Starter Posts: 770   +10

    RED

    sorry late reply. anyway, its color red.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...